Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-11-2010, 04:44 PM
lsmalley's Avatar
Registered User
 
Join Date: Oct 2006
Location: California
Posts: 1,939
190E tramsmission question

My gears seem to work fine while driving....shifting is normal. Howeber when I put the car in reverse I don't feel the slight jerk of the transmission engaging and the car sits for a while before it slowwwwwwly begins to back up. Even if I give it a little gas it will help a bit, but sounds like the car is in neutral when its in reverse. Any takers?
__________________

1990 190E 2.6L
Reply With Quote
  #2  
Old 10-13-2010, 01:09 AM
shingleback's Avatar
Registered User
 
Join Date: Jul 2006
Location: Vancouver, BC Canada
Posts: 265
Check ATF level; when was the last time the filter was changed?
__________________

'98 E300 DT
'87 190D 2.5 turbo RIP
'92 S500 Sold
'03 3.2TL-S A-Spec
Reply With Quote
  #3  
Old 10-13-2010, 02:34 AM
Registered User
 
Join Date: Jan 2008
Location: Melbourne Australia
Posts: 834
If you do change the filter, check the bottom of the transmission pan. Make sure there is no sediment in there. If there is sediment then you could be on your way to either a tranny rebuild or clutch pack replacement.
Reply With Quote
  #4  
Old 10-13-2010, 03:09 AM
lsmalley's Avatar
Registered User
 
Join Date: Oct 2006
Location: California
Posts: 1,939
filter changed 5/22/2010.
fluid was changed 5/22/2010, 7/3/2010 (flushed it like 4 times because the pan was leaking from uneven torque)
just drained all the fluid from the pan yesterday and added about 3.5 liters. I did not notice anything in the bottom off the pan. Today on my lunch break from work it was fine then it started again the next time I turned off the engine and put it in reverse.
__________________

1990 190E 2.6L
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page