Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-14-2010, 07:13 PM
Registered User
 
Join Date: Mar 2009
Posts: 153
96 W210 climate control problem

I think the head unit is dead. Display lights up. shows LO. I only have fan speed control, from off to hi. Nothing else works, press any button and nothing changes.
Reply With Quote
  #2  
Old 10-14-2010, 07:43 PM
Registered User
 
Join Date: Apr 1999
Location: N.E. Ohio
Posts: 152
I had similar problem with my 98 E320. Problem was blower motor/regulator.
I had to replace both regulator and motor. In some cases you may just need to replace the regulator.
__________________
Donwo
1999 SL 500 Sport (30K miles)
1998 E320 (SOLD)
1989 560SL (SOLD)
1987 300E (TOTALED)
1986 300E (SOLD)
1984 300SD (SOLD)
Reply With Quote
  #3  
Old 10-14-2010, 09:19 PM
Registered User
 
Join Date: Oct 2005
Posts: 4,263
If the regulator is causing the trouble, disconnecting it should fix that problem, but you'll have no fan.

I wouldn't think that a bad regulator would cause the head unit to go nuts, but I will easily concede the possibility if it is back-feeding current to the control line.

If it is the regulator and the blower motor is good, you can retrofit a regulator from a W140. The original regulator for your car is NLA, and you need a new motor and mounting plate to use the new regulator.
Reply With Quote
  #4  
Old 10-14-2010, 09:28 PM
Registered User
 
Join Date: Apr 1999
Location: N.E. Ohio
Posts: 152
Right Matt. i had to replace both reg and motor for my car.
__________________
Donwo
1999 SL 500 Sport (30K miles)
1998 E320 (SOLD)
1989 560SL (SOLD)
1987 300E (TOTALED)
1986 300E (SOLD)
1984 300SD (SOLD)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page