Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-28-2010, 12:02 PM
Registered User
 
Join Date: Apr 2010
Location: Joppa, MD
Posts: 26
a couple problems 1991 300SE

Econ gauge just today I noticed it doesnt work. its reading horrible economy all the time. just stays there. stuck to the right... no idea where it gets the reading from. not sure if i care about what it reads either. but something else could be wrong to make it do that. Any knowledge that may be bestowed...

Im pretty sure its what i think its is but slow clicking from the front when i make a left or right turn is...

passenger side engine mount was flat and i dont know what the driver side mount looked like. So I replaced both to be safe. new passenger mount is almost flat again within same week I put it on...

Reply With Quote
  #2  
Old 10-28-2010, 12:09 PM
david s poole
 
Join Date: Mar 2005
Location: dallas
Posts: 1,822
check the vacuum check valves in front of the fusebox you will find a loose conection for a least one vac line two options 1 replace valve 2 cut back silicon line and push back on to valve tightly.
__________________
David S Poole
European Performance
Dallas, TX
4696880422

"Fortune favors the prepared mind"
1987 Mercedes Benz 420SEL
1988 Mercedes Benz 300TE (With new evaporator)
2000 Mercedes Benz C280
http://www.w108.org/gallery/albums/A...1159.thumb.jpg
Reply With Quote
  #3  
Old 10-31-2010, 06:18 PM
Registered User
 
Join Date: Apr 2010
Location: Joppa, MD
Posts: 26
found a vacuum hose that was loose. works now. thx
Reply With Quote
  #4  
Old 10-31-2010, 07:57 PM
sptt's Avatar
Registered User
 
Join Date: Sep 2009
Location: Orange County, California
Posts: 691
Isn't it great when it's easy....?

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page