Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-02-2010, 12:14 AM
Registered User
 
Join Date: May 2006
Posts: 19
w220 weird suspension problem

2000 S500 w/o 4matic
116k

Replaced struts (front) all went well suspension normal.

One month later:

Car rises as it suppose too, when it reaches ride height, it lowers, but not on stops. The ride is really rough.
The "stop car warning light" does not come on, as the car is really not that low.

When i press the switch to raise the car it raises.
The funny thing is that i don't hear the pump any more, only ait going into something.
can this problem be a relay or fuse ( where are they?) or is this a fail compressor, please help, this is only happening on the front, back seems fine, i hope. can anyone please help

Charles Kimble
2000 S500
1992 190E 2.6 224K
2007 S550 19K

Reply With Quote
  #2  
Old 11-02-2010, 08:07 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
The level of the car should NOT drop overnight?
Designed to hold level for minimun of 2-3 weeks under normal conditions.

If the car is dropping either front, rear, OR both, there must be a leak.

The distribution valve block is the most likely cause.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 11-02-2010, 09:07 AM
Registered User
 
Join Date: May 2006
Posts: 19
Shouid I hear the compressor, at all
Reply With Quote
  #4  
Old 11-02-2010, 09:25 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
The compressor runs to fill the reservoir & then the air is sent to each of the struts as needed.

Pump should run every 5 or so minutes as you drive. And only for 10-15 seconds to fill the reservoir.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #5  
Old 11-02-2010, 03:20 PM
Registered User
 
Join Date: May 2006
Posts: 19
Where is The distribution valve block, the fuse and relay associated withe air matic system.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page