Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-22-2010, 04:18 PM
Registered User
 
Join Date: Oct 2005
Location: Toronto
Posts: 78
94 E320 W124 Overheating

On my way home from work I noticed the temp going towards 120... so i pulled into a gas station and revved at 3500-5000 rpm which usually brings the temp down. It came down 10 degres and then started rising again..

so i shut off the car. And heard a gargle like sound from the dash.

Towed it to my idie and he said the water pump was done. So thats being replaced now. However i think it was the viscous fan that failed first..

any comments on if this makes sense??

__________________
94 E320 - Sold
Reply With Quote
  #2  
Old 11-22-2010, 05:13 PM
RANDY P's Avatar
Registered User
 
Join Date: Oct 2008
Location: Paris, Madrid, NYC, Mesa
Posts: 159
the gargle you heard was probably due to no water in the system.

Look at the water pump, is it leaking? I'll bet it is. The indy is right.
__________________
03 540I (GAK!!)
81 280E (W123)
70 LeMans Sport with pissed off Poncho 462"
1989 Silverado Step Side (under the knife- complete restomod)
Reply With Quote
  #3  
Old 11-22-2010, 05:53 PM
Registered User
 
Join Date: Dec 2009
Location: Mount Pleasant, SC
Posts: 103
the gargle you heard was the water boiling....
__________________
Tim

05 E320
86 930
05 Range Rover HSE
95 Range Rover SWB
63 Series IIa
Several boring BMW's for this kids....
Reply With Quote
  #4  
Old 11-22-2010, 05:53 PM
ps2cho's Avatar
Registered User
 
Join Date: Jun 2006
Location: Chandler, Arizona
Posts: 3,523
Viscous fan is fine if you reved it and temperatures went down. It is easy to check though....Stone cold from being left alone overnight. Spin it by hand in the AM....If it spins more than 1/3rd of a turn it is done for. More than 1/2 and it is definitely done for.

Your water pump probably started pissing out the weep hole at the bottom. Easy check if you remove the thermostat, fill up directly into the pump and see if it leaks out.

Always check fluid level #1 item when overheating occurs.
__________________
2016 Monsoon Gray Audi Allroad - 21k
2008 Black Mercedes E350 4Matic Sport - 131k
2014 Jeep Wranger Unlimited Sahara - 62k
2003 Gray Mercedes ML350 - 122k
Reply With Quote
  #5  
Old 11-22-2010, 07:58 PM
Registered User
 
Join Date: Oct 2005
Location: Toronto
Posts: 78
the water pump was leaking. so..has to be changed.

But when I revved it came down about 10 degrees but then went back up and never came down after subsequent revvs...

I will check with the "spin test" tomorrow.

Thanks so far guys.
__________________
94 E320 - Sold
Reply With Quote
  #6  
Old 11-23-2010, 06:52 AM
Registered User
 
Join Date: Aug 2002
Location: Southeastern PA
Posts: 3,035
jm124, recommend buying a reconditioned water pump from your local MB dealer because it will have a 1 year warranty.
__________________
Fred Hoelzle
Reply With Quote
  #7  
Old 11-23-2010, 07:26 AM
Registered User
 
Join Date: Oct 2004
Location: Baton Rouge La
Posts: 2,631
the gurgling is lack of water.
__________________
1989 300ce 129k
( facelifted front,updated tail lights, lowered suspension,bilstein sports, lorinser front spoiler, MOMO steering wheel, remus exhaust,stainless steel brake lines). (Gone)

1997 s320 154k (what a ride). Sold with 179k miles. Replaced with Hyundai Equus

1994 e320 Cabriolet 108k



1972 280se 4.5 153k Owned for 12 yrs, sorry I sold it


[/SIGPIC]
Reply With Quote
  #8  
Old 11-23-2010, 08:47 AM
TheDon's Avatar
Ghost of Diesels Past
 
Join Date: Oct 2005
Posts: 13,217
bad thermostat?
Reply With Quote
  #9  
Old 11-23-2010, 02:17 PM
ps2cho's Avatar
Registered User
 
Join Date: Jun 2006
Location: Chandler, Arizona
Posts: 3,523
Go with OE or Graf since they are the ONLY other manufacturer to use OE bearings and seals. I've been happy with my Graf pump so far on my wagon. No issues.
__________________
2016 Monsoon Gray Audi Allroad - 21k
2008 Black Mercedes E350 4Matic Sport - 131k
2014 Jeep Wranger Unlimited Sahara - 62k
2003 Gray Mercedes ML350 - 122k
Reply With Quote
  #10  
Old 12-09-2010, 12:30 AM
Registered User
 
Join Date: Oct 2005
Location: Toronto
Posts: 78
Ok. Here is the final update. I decided to go with the pump from MB(CAD328). but apparently there was a plug and adhesive required for 60 bucks more as they only made this WP with an extra opening or something...

So far its been a week and the car is running cool right in the middle of the temp guage just about 80.

All is well and i'm glad to have my w124 back on the road.

Thank you to all who helped me out!

__________________
94 E320 - Sold
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page