Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-27-2010, 08:31 PM
Registered User
 
Join Date: Oct 2004
Location: Baton Rouge La
Posts: 2,632
2.6 103 o2 Sensor

I just picked up a 1992 190e with 70k miles, lots of service records but no record of a replaced o2 sensor.


Car seems to accelerate with a bit of hesitation. I will replace the plugs and have already ordered motor mounts to correct the vibration in drive issue.

I can't seem to find a cel light.

Anyway... does it have a cel light.... and will a generic 3 wire bosch work

I also have a spare generic 4 wire.

I know it will take me several weeks to sort it out...

Great service history on the car...over-serviced.

__________________
1989 300ce 129k
( facelifted front,updated tail lights, lowered suspension,bilstein sports, lorinser front spoiler, MOMO steering wheel, remus exhaust,stainless steel brake lines). (Gone)

1997 s320 154k (what a ride). Sold with 179k miles. Replaced with Hyundai Equus

1994 e320 Cabriolet 108k



1972 280se 4.5 153k Owned for 12 yrs, sorry I sold it


[/SIGPIC]
Reply With Quote
  #2  
Old 11-28-2010, 06:01 AM
css190e's Avatar
Registered User
 
Join Date: Oct 2008
Location: denver,co
Posts: 38
I believe that the o2 sensor should be replaced @ 75k intervals .. I used NGK plugs &
o2 sensor which worked fine . The 3 wire should work for you . Funny , my CEL didn't go on when my o2 sensor died.(OBD1) Had to find that out at the Colorado emissions testing station.aargh..
Also, I would have a good indie look at all the emission components..they all work hand in hand, too rich fuel mix can kill your Cat.. I wound up getting a new cat also.The stealership wanted $1600.I spent 325.00 at a local muffler shop est. 1954..so I trusted them..Unless you are rich, stay away from the dealership.$50 for a thermostat mind you.
Lastly, these forms are invaluable,Thanks WHUNTER and all those who contribute and help me to save $$$. My 3 kids in college thank you all also,not my wife so much.
Reply With Quote
  #3  
Old 11-28-2010, 01:05 PM
ps2cho's Avatar
Registered User
 
Join Date: Jun 2006
Location: Chandler, Arizona
Posts: 3,523
As long as it has 2 white heater and one black signal then it should work.

I used generic 3 wire sensor // Bosch part #13942.
__________________
2016 Monsoon Gray Audi Allroad - 21k
2008 Black Mercedes E350 4Matic Sport - 131k
2014 Jeep Wranger Unlimited Sahara - 62k
2003 Gray Mercedes ML350 - 122k
Reply With Quote
  #4  
Old 11-28-2010, 02:17 PM
Registered User
 
Join Date: Oct 2004
Posts: 3,688
In 92 only Calif. cars should have a C/E light.
__________________

90 300TE 4-M
Turbo 103, T3/T04E 50 trim
T04B cover .60 AR
Stage 3 turbine .63 AR
A2W I/C, 40 LB/HR
MS2E, 60-2 Direct Coil Control
3" Exh, AEM W/B O2
Underdrive Alt. and P/S Pulleys,
Vented Rear Discs, .034 Booster.
3.07 diffs 1st Gear Start

90 300CE
104.980
Milled & ported head, 10.3:1 compression
197 intake cam w/20 advancer
Tuned CIS ECU
4 ignition advance
PCS TCM2000, built 722.6
600W networked suction fan
Sportline sway bars
V8 rear subframe, Quaife ATB 3.06 diff
Reply With Quote
  #5  
Old 11-29-2010, 02:11 PM
Registered User
 
Join Date: Oct 2004
Location: Baton Rouge La
Posts: 2,632
Quote:
Originally Posted by duxthe1 View Post
In 92 only Calif. cars should have a C/E light.
How would you know if your o2 sensor is bad...

poor mileage?

anyway, i replaced mine with a bosch generic. it came with anti-sieze on the threads.

i had to use some pb blaster to loosen what i think was the original. (70k) miles

__________________
1989 300ce 129k
( facelifted front,updated tail lights, lowered suspension,bilstein sports, lorinser front spoiler, MOMO steering wheel, remus exhaust,stainless steel brake lines). (Gone)

1997 s320 154k (what a ride). Sold with 179k miles. Replaced with Hyundai Equus

1994 e320 Cabriolet 108k



1972 280se 4.5 153k Owned for 12 yrs, sorry I sold it


[/SIGPIC]
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page