Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-03-2010, 07:41 PM
Registered User
 
Join Date: Apr 2005
Location: Northern Louisiana
Posts: 448
1986 420 SEL Freaks Out!! What Just Happened??

Washed the 420 this afternoon then took it out for about 5 miles. As I was turning into the drive the headlights, already on, started flashing and some sort of horn-like device started sounding repeatedly. This lasted maybe 5 seconds, then it stopped. I drove up to the garage door and stopped; engine was running normally, etc.
Was this some sort of alarm system? I've owned Her 6 years and never had this happen before.

Reply With Quote
  #2  
Old 12-03-2010, 08:12 PM
whunter's Avatar
Moderator
 
Join Date: Dec 2003
Location: Metro Detroit, Michigan
Posts: 17,358
Answer

Factory Alarm System Issues
http://www.peachparts.com/shopforum/diesel-discussion/150748-factory-alarm-system-issues.html#post1143583





.
__________________
ASE Master Mechanic
asemastermechanic@juno.com

Prototype R&D/testing:
Thermal & Aerodynamic System Engineering (TASE) Senior vehicle instrumentation technician.
Noise Vibration and Harshness (NVH).
Dynamometer.
Heat exchanger durability.
HV-A/C Climate Control.
Vehicle build.
Fleet Durability
Technical Quality Auditor.
Automotive Technical Writer

1980 240D
1983 300D
1984 190D
Reply With Quote
  #3  
Old 12-03-2010, 08:34 PM
Registered User
 
Join Date: Feb 2007
Location: los angeles
Posts: 675
Check door handle plugins inside door, most likely water got into plug , dry or seal the male /female plug so water cant get in (if water is found in plug/connector) only front doors have plug water issues
Reply With Quote
  #4  
Old 12-07-2010, 02:02 AM
86560SEL's Avatar
Registered User
 
Join Date: Jan 2003
Location: east Tennessee (southeast USA)
Posts: 3,015
My W126 did this about 20 months ago... it did it random for a week, then quit on its own and hasnt sounded off randomly again.
Reply With Quote
  #5  
Old 12-08-2010, 08:35 PM
Registered User
 
Join Date: Jul 2008
Posts: 1,236
W126 Factory alarms suck. You'll want to remove it. It's under the passenger side kick panel. It's a black box with two large wiring harnesses attached, and if the sticker is still on it, it says "Becker Autoradio"

You can just unplug both harnesses and everything will be fine.
__________________
-tp


1990 300SE "Corinne"- 145k daily driver - street modified differential - PARTING OUT OR SELLING SOON - PORTLAND OR. AREA - PM ME FOR DETAILS
1988 560SEL "Gunther"- 190K passes anything except a gas station
1997 S420 - 265k just bought it with a rebuilt trans. Lovely condition
Reply With Quote
  #6  
Old 03-05-2014, 05:54 PM
Dubyagee's Avatar
All fields are required
 
Join Date: Jul 2006
Location: SE
Posts: 5,910
'86 420 SEL Freaks Out!! What Just Happened??

Just now ripped mine out with impunity on the side of the interstate. If anyone needs the factory alarm, theres one in the median of I16 at mile marker 157.

Heres what it looked like after a bare handed uninstall.


Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page