Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-07-2010, 09:36 PM
Registered User
 
Join Date: May 2009
Location: Hudson Valley New York
Posts: 19
1987 300E

Due to divorce and a move i had to sell my 1972 220d.I just picked up my next project - a 1987 300E. I'll be asking alot of questions as this model is new to me. The car runs nice and doesnt shift badly. Heres a list of what doesnt work.
2 power windows
sunroof
cruise contol
front headrests
ambient temp guage
e-brake
passenger front power seat doesnt go back - the back works and will go forward just not back

I am looking forward to getting car fully functional again as it drives wonderfully
Thanxx in advance

Reply With Quote
  #2  
Old 12-07-2010, 11:22 PM
sptt's Avatar
Registered User
 
Join Date: Sep 2009
Location: Orange County, California
Posts: 691
If all windows do not work, check your fuses. Just order a batch of new fuses and replace all of them. You'll be surprised what they fix! You can try to clean the contact switches in the doors for seat adjustments as they wear out for your headrests and adjustments. Search these forums. Or, order new ones off Ebay. Also could be cables that are rounded out at ends under seat going into drive gears. I replaced both and fixed mine...everything works perfect now. Sunroof...87's are notorious and if fuse doesn't work, just consider it a hard top. E-Brake....mechanical. Should be easy. Cruise control...can't help you. Mine works fine. Best of luck.

Steve
Reply With Quote
  #3  
Old 12-08-2010, 01:04 AM
mbzman's Avatar
Registered User
 
Join Date: Nov 2008
Location: Canada
Posts: 600
Checking the fuses is most definitely a good place to start. If cleaning the power seat switches does not correct the headrests then you will have to go a bit deeper. The headrests are driven by a gear assembly inside the seatback and they do fail as they get older. If you do a search you should be able to find info on replacing the gear assembly. Does the ambient temperature gauge show a reading or is the screen blacked out? The display is a common failure point and can be replaced relatively easily by removing the instrument cluster where it is screwed on. A working display can often be found for $30-$50 online or at your local salvage yard.
__________________
1989 300CE
Reply With Quote
  #4  
Old 12-08-2010, 01:49 AM
ps2cho's Avatar
Registered User
 
Join Date: Jun 2006
Location: Chandler, Arizona
Posts: 3,523
Make sure you get the all fluids and filters changed asap. Especially since you mention the transmission "doesn't shift badly"

After checking the fuses for the windows, establish if it is the wiring or the motor that is dead. Pull the panels off and apply a 12V battery to the terminal attached to the door to see if the motor moves. If it does, wiring is frayed in the door, if not, motor replacement!
__________________
2016 Monsoon Gray Audi Allroad - 21k
2008 Black Mercedes E350 4Matic Sport - 131k
2014 Jeep Wranger Unlimited Sahara - 62k
2003 Gray Mercedes ML350 - 122k
Reply With Quote
  #5  
Old 12-09-2010, 09:12 PM
Registered User
 
Join Date: May 2009
Location: Hudson Valley New York
Posts: 19
start working on it tomorrow - have to replace headlights also (received those today) - gonna do the fluid changes also have to replace valve cover gasket - the headrests, drivers side missing switch.the pass side when you use switch you can feel it move in the seat but it doesnt move the rest its self. The pass windows tha dont work, when you hit the switch the lights dim but they dont move. the temp gauge is black - found one on ebay for 25.the things that surprise me is the dash clock doesnt lose a minute and the rear defroster works great.Also the seat adjustment switches only work if the door is open - i find that perplexing.Thank you guys for the help so far, this at first seemed a daunting task but looks like i'll be able to get this beauty back roadworthy soon.
Reply With Quote
  #6  
Old 12-10-2010, 07:00 AM
JimFreeh's Avatar
Benz addict
 
Join Date: Mar 2007
Location: Hampton Roads, Virginia
Posts: 3,353
Quote:
Originally Posted by marvin9679 View Post
start working on it tomorrow - have to replace headlights also (received those today) - gonna do the fluid changes also have to replace valve cover gasket - the headrests, drivers side missing switch.the pass side when you use switch you can feel it move in the seat but it doesnt move the rest its self. The pass windows tha dont work, when you hit the switch the lights dim but they dont move. the temp gauge is black - found one on ebay for 25.the things that surprise me is the dash clock doesnt lose a minute and the rear defroster works great.Also the seat adjustment switches only work if the door is open - i find that perplexing.Thank you guys for the help so far, this at first seemed a daunting task but looks like i'll be able to get this beauty back roadworthy soon.
Headrest - broken gear. Remove seatback and investigate. Screw at bottom, then pull down.

Windows - sounds like you have power, remove door panel. Screws at lock plate at rear, remove black plastic behind door handle to find screw, then remove door handle and then seat switch. Check to see if the regulator is bound up. Door panel lifts UP to remove. Be very careful not to break any of the hooks.

Temp display - Earlier cars had different pin out than later. Check archives for fitting a later one.

Seat adjustment - Seat switch will work only if door is open OR if ignition is turned on. Key off, door closed, no power....


Jim
__________________
14 E250 BlueTEC black
94 E320 Cabriolet Emerald green
85 300TD 4 spd manual dark blue
Reply With Quote
  #7  
Old 12-10-2010, 10:01 PM
ps2cho's Avatar
Registered User
 
Join Date: Jun 2006
Location: Chandler, Arizona
Posts: 3,523
The temperature display will not work unless you have the same type. Different circuit boards and pin layouts. I see (I have tried) no way to mix/match or make it work. Just the way it is.

__________________
2016 Monsoon Gray Audi Allroad - 21k
2008 Black Mercedes E350 4Matic Sport - 131k
2014 Jeep Wranger Unlimited Sahara - 62k
2003 Gray Mercedes ML350 - 122k
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page