Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-14-2010, 12:53 PM
Registered User
 
Join Date: Dec 2003
Location: Palm Springs, CA
Posts: 781
Gas fill problems

Checked the archives but couldn't nail my problem. I was on a long trip and gassed up. The pump shut off. I put on the gas cap and was talking to the guy at the next pump when suddenly I smelled gas. I noticed a pool of gas under the trunk on the pavement. I took the gas cap off and "whoosh" a 1/2 cup of gas sprayed out. The same thing happened later that day at the next fill up. It acts like pressure builds AFTER the cap is replaced on the fill up. The car is my '93 300CE. Any ideas?
Anziani
'93 300CE 192K
'95 E420 122K

Reply With Quote
  #2  
Old 12-14-2010, 09:04 PM
Registered User
 
Join Date: Jul 2008
Posts: 1,236
Venting issue leading to the tank changing its size?

This is completely wild ass speculation and hypothesis here, but let's say that there was a tank venting issue that makes your tank bulge. You then pump in a bunch of gas into this bulging tank. The cool gas makes the metal tank contract and suddenly the bulging tank side pops back to its original smaller shape, making it too small to hold all the gas you have just pumped in....

Yeah, I know. It's a stretch. But it's the only thing I can think of that makes sense.

Do you ever hear noises that could be the gas tank changing shape?
__________________
-tp


1990 300SE "Corinne"- 145k daily driver - street modified differential - PARTING OUT OR SELLING SOON - PORTLAND OR. AREA - PM ME FOR DETAILS
1988 560SEL "Gunther"- 190K passes anything except a gas station
1997 S420 - 265k just bought it with a rebuilt trans. Lovely condition
Reply With Quote
  #3  
Old 12-15-2010, 08:24 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Sounds like the charcoal canister under the LF fender has a issue.
OR could be the check valve under the hood that attaches to the hose that connects to the canister.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #4  
Old 12-15-2010, 11:35 AM
Registered User
 
Join Date: Dec 2003
Location: Palm Springs, CA
Posts: 781
Thanks guys for the suggestions. Will start off with the easy fix first, the check valve.
Filled it up last night but lifted the hose a couple of times while filling. Everything went well. This tells me that the pressure is not being vented internally.
Anziani

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page