Parts Catalog Accessories Catalog Tech Info Tech Forums
 
  Search our site:    
 Cart  | Project List | Order Status | Help    


Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-05-2011, 08:05 PM
LandYaghtLover's Avatar
Registered User
 
Join Date: Jun 2010
Location: Green Bay, WI
Posts: 1,299
W126 Sun visor micro switches?

Mine are, oddly, both bad. Power to switch, nothing after. Anyone happen to know the part number from an electronics source or at least the exact type? I need to order some stuff, capacitors and what not, but have been putting it off since I can not ID these things.
__________________
1991 560 SEL / 185k miles
1992 750il / 17k miles - project car
Reply With Quote
  #2  
Old 01-06-2011, 12:48 AM
compu_85's Avatar
On the road again!
 
Join Date: May 2008
Location: Springfield VA
Posts: 4,798
Can you post a pic?

-J
__________________
1991 350SDL. 230,000 miles (new motor @ 150,000).

2012 Passat TDI. 50,000 miles. More space, power, and fuel economy than the Benz
1999 Jetta TDI. 295,000 miles.
1992 Jetta ECOdiesel. 156,000 miles. 1 of 48. Sold.
1991 Jetta ECOdiesel. 430,000 miles. 1 of 700. Sold to VeeDubTDI, totaled in front of our house
Reply With Quote
  #3  
Old 01-06-2011, 12:57 AM
Registered User
 
Join Date: Mar 2009
Location: San Diego
Posts: 1,939
It may be bad contact not the microswitch. Have you tried cleaning the contacts on the visor clip and the tip of the visor? That is where it get +12V. The ground is from the screws which hold the visor in place, chean that too. Or check the fuse.

Easy way to check is to put 12V on the visor and flip the mirror cover.
__________________
Not MBZ nor A/C trained professional but a die-hard DIY and green engineer. Use the info at your own peril. Picked up 2 Infractions because of disagreements. NOW reversed.

W124 Keyless remote, PM for details. http://www.peachparts.com/shopforum/mercedes-used-parts-sale-wanted/334620-fs-w124-chasis-keyless-remote-%2450-shipped.html

2 x 87 300SDL
1 x 87 300D
1 x 83 300D
1 x 84 190D ( 5 sp ) - All R134 converted + keyless entry.
Reply With Quote
  #4  
Old 01-06-2011, 08:54 AM
LandYaghtLover's Avatar
Registered User
 
Join Date: Jun 2010
Location: Green Bay, WI
Posts: 1,299
ah-kay. I did all that and more. I removed the covers, took them apart and re-sodlered them. ALL the solder joints where cracked on both. I really thought that was the issues until I put them back in. I never put the mirrors back in so I could continue testing. I checked power and the outputs of the switch itself the last time.

Odd that BOTH would go back. I thought it was originally a related issue to my non-functiong memory seating or some other common power issue.

Anyway, I will see if I can grab a pic.
__________________
1991 560 SEL / 185k miles
1992 750il / 17k miles - project car
Reply With Quote
  #5  
Old 01-06-2011, 08:52 PM
Registered User
 
Join Date: Jan 2009
Posts: 2
You can buy microswitches at radio shack for about $2.69. I did. I can't find the part number right now, but I will look. The switch is not identical, but it works exactly the same. too easy.
Reply With Quote
Old 01-06-2011, 08:52 PM
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 02:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page