Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-19-2011, 03:38 PM
Graplr's Avatar
Registered User
 
Join Date: Apr 2007
Location: Redlands, CA
Posts: 1,577
My "New" Mercedes

I picked up my 2000 E320 4Matic Wagon from a forum member on Sunday. I flew in and drove it back about 300 and some change miles back home. I love it! It has just over 130k miles on it and it is pretty good shape. The pictures are from the seller as I haven't taken any on my own yet.

I've been wanting a wagon for a long time. This will be my daily driver and family trip hauler.

Attached Thumbnails
My "New" Mercedes-mercedes-003.jpg   My "New" Mercedes-mercedes-005.jpg   My "New" Mercedes-mercedes-016.jpg   My "New" Mercedes-mercedes-020.jpg   My "New" Mercedes-mercedes-022.jpg  

__________________
2004 E320 Wagon

Past Mercedes
1979 300TD
1982 300TD
2000 E320 4Matic Wagon
1998 E430
1984 300SD
1980 300SD
Reply With Quote
  #2  
Old 01-19-2011, 03:48 PM
TX76513's Avatar
Platinum Member
 
Join Date: Apr 2003
Location: Brandon, Mississippi
Posts: 5,203
Nice, Good miles for a 2000
__________________
BENZ THERE DONE THAThttp://www.peachparts.com/shopforum/...c/progress.gif
15 VW Passat TDI
00 E420
98 E300 DT
97 E420 Donor Car - NEED PARTS? PM ME!
97 S500
97 E300D
86 Holden Jackaroo Turbo D
86 300SDL
(o\|/o)
Reply With Quote
  #3  
Old 01-19-2011, 06:47 PM
Aquaticedge's Avatar
Bump on a log
 
Join Date: Nov 2009
Location: See Biography
Posts: 3,148
Nice looking wagon
__________________
hum.....
1987 300TD 311,000M Stolen. Presumed destroyed
Reply With Quote
  #4  
Old 01-19-2011, 08:53 PM
RichardM98's Avatar
Registered User
 
Join Date: Oct 2007
Location: SoCal
Posts: 651
Congratulations! Looks very nice. I bought a'98 wagon with 120000 miles 3 years ago and haven't regretted it for a moment. If you are new to the W210 read and reread the Owners Manual a few times to figure out all the bells and whistles.
Reply With Quote
  #5  
Old 01-20-2011, 07:45 AM
Graplr's Avatar
Registered User
 
Join Date: Apr 2007
Location: Redlands, CA
Posts: 1,577
Thanks guys. I really do love it.

I am new to W210s and I read the manual cover to cover the first night I had it.

Only two issues I've notice so far. The outside temp display is not working. Sometimes I get one line showing up on the display. I would imagine I would need to get a new cluster display to fix it? One fog lamp must bout because I get a lamp malfunction when I turn them on.

It also has a set of Blizzaks on right now so I am looking for a set of wheels for summer tires.
__________________
2004 E320 Wagon

Past Mercedes
1979 300TD
1982 300TD
2000 E320 4Matic Wagon
1998 E430
1984 300SD
1980 300SD
Reply With Quote
  #6  
Old 01-20-2011, 08:44 AM
Stretch's Avatar
...like a shield of steel
 
Join Date: Sep 2009
Location: Somewhere in the Netherlands
Posts: 14,457
Nice car - very clean - though there seems to be a bit of paper on the front of it that might cause problems with the police!
__________________
1992 W201 190E 1.8 171,000 km - Daily driver
1981 W123 300D ~ 100,000 miles / 160,000 km - project car stripped to the bone
1965 Land Rover Series 2a Station Wagon CIS recovery therapy!
1961 Volvo PV544 Bare metal rat rod-ish thing

I'm here to chat about cars and to help others - I'm not here "to always be right" like an internet warrior



Don't leave that there - I'll take it to bits!
Reply With Quote
  #7  
Old 01-20-2011, 09:15 AM
Registered User
 
Join Date: Aug 2002
Location: Southeastern PA
Posts: 3,018
Grapir, recommend getting a set of the E430 5-hole wheels for Summer tires. They are much easier to clean. I have the 5-hole wheels on our 1998 E320 so I know from experience.
__________________
Fred Hoelzle
Reply With Quote
  #8  
Old 01-20-2011, 10:06 AM
Graplr's Avatar
Registered User
 
Join Date: Apr 2007
Location: Redlands, CA
Posts: 1,577
Quote:
Originally Posted by Army View Post
Nice car - very clean - though there seems to be a bit of paper on the front of it that might cause problems with the police!
Well I drove it home 300 plus miles by about 5 cop cars with no license plates and I had no problems. I do of course have MN plates on it now.
__________________
2004 E320 Wagon

Past Mercedes
1979 300TD
1982 300TD
2000 E320 4Matic Wagon
1998 E430
1984 300SD
1980 300SD

Last edited by Graplr; 01-20-2011 at 12:20 PM.
Reply With Quote
  #9  
Old 01-20-2011, 10:50 AM
Stretch's Avatar
...like a shield of steel
 
Join Date: Sep 2009
Location: Somewhere in the Netherlands
Posts: 14,457
Quote:
Originally Posted by Graplr View Post
Well I drove it home 300 plus miles buy about 5 cop cars with no license plates and I had no problems. I do of course have MN plates on it now.
I'm glad to see that tax payers' money is well spent in other countries too! (meaning they must be busy catching criminals and not eating doughnuts like they insist they do on the TV)

Enjoy your new daily driver
__________________
1992 W201 190E 1.8 171,000 km - Daily driver
1981 W123 300D ~ 100,000 miles / 160,000 km - project car stripped to the bone
1965 Land Rover Series 2a Station Wagon CIS recovery therapy!
1961 Volvo PV544 Bare metal rat rod-ish thing

I'm here to chat about cars and to help others - I'm not here "to always be right" like an internet warrior



Don't leave that there - I'll take it to bits!
Reply With Quote
  #10  
Old 01-20-2011, 11:33 AM
RichardM98's Avatar
Registered User
 
Join Date: Oct 2007
Location: SoCal
Posts: 651
Quote:
Originally Posted by Graplr View Post
Thanks guys. I really do love it.

Only two issues I've notice so far. The outside temp display is not working. Sometimes I get one line showing up on the display. I would imagine I would need to get a new cluster display to fix it? One fog lamp must bout because I get a lamp malfunction when I turn them on.
The sensor for the outside temperature in located in the lower bumper just inside of the left fog lamp. It's black plastic about 3/4" in dia. with a pointed end. Start there to check for the problem. Also there are bulbs which illuminate the instrument cluster. If the lower left one is burned out, the temp is very difficult to read especially if the illumination is turned down. Repeatedly press the '+' button to see if there's a reading. To remove the cluster (friction fit) you need a set of cluster hooks.

A more serious problem is 'missing pixels'. A few people have worked on the ribbon cable which connects to the display with varying levels of success. If necessary there are a couple of companies which do repairs.

The left fog light is an issue for W210's as well as the left stop light. Actually, getting false positives on burned out bulbs is pretty common. If the light is out but the bulb and fuse are ok, try cleaning the contacts. Next examine the socket and housing for signs of overheating. You'll need to remove the front anti-noise panel. If the socket is shot, MB makes a repair kit which includes the socket and a pigtail to splice into the harness. Although, some newer models have a quick connect.

Good luck.
Reply With Quote
  #11  
Old 01-20-2011, 12:43 PM
Graplr's Avatar
Registered User
 
Join Date: Apr 2007
Location: Redlands, CA
Posts: 1,577
Quote:
Originally Posted by Army View Post
I'm glad to see that tax payers' money is well spent in other countries too! (meaning they must be busy catching criminals and not eating doughnuts like they insist they do on the TV)

Enjoy your new daily driver
I did have the title taped in the back window to show I had just purchased it. It was literally ALL freeway driving, so it was hard to notice as the cops were sitting perpendicular to the freeway.
__________________
2004 E320 Wagon

Past Mercedes
1979 300TD
1982 300TD
2000 E320 4Matic Wagon
1998 E430
1984 300SD
1980 300SD
Reply With Quote
  #12  
Old 01-20-2011, 12:46 PM
Graplr's Avatar
Registered User
 
Join Date: Apr 2007
Location: Redlands, CA
Posts: 1,577
Quote:
Originally Posted by RichardM98 View Post
The sensor for the outside temperature in located in the lower bumper just inside of the left fog lamp. It's black plastic about 3/4" in dia. with a pointed end. Start there to check for the problem. Also there are bulbs which illuminate the instrument cluster. If the lower left one is burned out, the temp is very difficult to read especially if the illumination is turned down. Repeatedly press the '+' button to see if there's a reading. To remove the cluster (friction fit) you need a set of cluster hooks.
It doesn't seem like a sensor issue since there is almost no display. But I would assume that would be much easier to fix, so I'll start there (when I have time ). I doubt it is the instrument bulb being burnt out because I can clearly see one line sometimes but nothing else.

Quote:
Originally Posted by RichardM98 View Post

A more serious problem is 'missing pixels'. A few people have worked on the ribbon cable which connects to the display with varying levels of success. If necessary there are a couple of companies which do repairs.

The left fog light is an issue for W210's as well as the left stop light. Actually, getting false positives on burned out bulbs is pretty common. If the light is out but the bulb and fuse are ok, try cleaning the contacts. Next examine the socket and housing for signs of overheating. You'll need to remove the front anti-noise panel. If the socket is shot, MB makes a repair kit which includes the socket and a pigtail to splice into the harness. Although, some newer models have a quick connect.

Good luck.
Thanks for the info on fog lights.
__________________
2004 E320 Wagon

Past Mercedes
1979 300TD
1982 300TD
2000 E320 4Matic Wagon
1998 E430
1984 300SD
1980 300SD
Reply With Quote
  #13  
Old 01-20-2011, 01:28 PM
Hirnbeiss's Avatar
ich fahre, also bin ich
 
Join Date: Mar 2002
Location: South Florida
Posts: 1,654
Don't you guys have dirt up there in Minn? Also, where's the rust?
__________________
Prost!
Reply With Quote
  #14  
Old 01-20-2011, 01:31 PM
Graplr's Avatar
Registered User
 
Join Date: Apr 2007
Location: Redlands, CA
Posts: 1,577
Quote:
Originally Posted by Hirnbeiss View Post
Don't you guys have dirt up there in Minn? Also, where's the rust?
There actually is a bit of surface rust in two places that I need to address before it gets worse.
__________________
2004 E320 Wagon

Past Mercedes
1979 300TD
1982 300TD
2000 E320 4Matic Wagon
1998 E430
1984 300SD
1980 300SD
Reply With Quote
  #15  
Old 01-20-2011, 04:21 PM
Rebe
Guest
 
Posts: n/a
Glad you found the nice Mercedes you were looking for. Enjoy!!

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page