Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-02-2011, 11:54 PM
johnflight1's Avatar
Registered User
 
Join Date: Aug 2002
Location: Las Vegas Nevada
Posts: 260
Unhappy Blower motor regulator symptoms?

I have looked at all the DIY stuff on climate control ,but there is nothing specific on the blower motor regulator/resistor. How do you know if it is bad? I took everything apart lubed the motor bearings spins ok now. But the fan only works in high no auto no low. The fan bearings got squeekie a few weeks ago and I did detect a faint smell of an electrical burning,which eventually went away. To get it to work in auto or low back then you would have to start off in high and work your way down to auto or low. Then it failed altogether.I thought this was due to the motor bearings having a high turning resistance ,but I have since corrected this problem and the fan turns ok now just no auto or low setting??? bad regulator or shoud I get to soldering the ccu joints?? Thanx John................................................................................................ ..

__________________
88 W124 3.0
96 R129 119eng
06 ML350
98 ML320 sold
02 CLK55 amg
Reply With Quote
  #2  
Old 02-03-2011, 12:37 AM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
That's the usual symptom, high blower speed and nuttin' else. The high resistance probably fried the regulator. I would have replaced the motor, or at least put new brushes in it.
Reply With Quote
  #3  
Old 02-03-2011, 06:40 PM
johnflight1's Avatar
Registered User
 
Join Date: Aug 2002
Location: Las Vegas Nevada
Posts: 260
88 300 E blower regulator

Thanx Gilly,thats what I thought.
A weird thing happened on the way to work,It started to work in auto and low then it started to cut in and out even in high. If the regulator is bad could it be intermittent or once its gone its gone???
__________________
88 W124 3.0
96 R129 119eng
06 ML350
98 ML320 sold
02 CLK55 amg
Reply With Quote
  #4  
Old 02-03-2011, 06:55 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Could be intermittent, sure. Might pay to look those brushes over now before you spend any money.
Reply With Quote
  #5  
Old 02-05-2011, 06:19 PM
Registered User
 
Join Date: Dec 2008
Location: N. Texas
Posts: 58
Where would the regulator be on a 126?

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page