Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-14-2002, 02:33 PM
Posts: n/a
High Idle

Alright so i think i have a high idle, im not sure though, but it has all the symptoms of it, here they are: When switching to reverse car is forced back very hard, same in drive, slows down when i let go of the accelerator when going fast, and of course the RPM gauge says somewhere around 700-800 which is high....So how do i lower the idle, should i take it to a shop?

Thank You for your responses....
Reply With Quote
Old 01-14-2002, 03:17 PM
dpetryk's Avatar
Electrons can do anything
Join Date: Sep 2001
Location: Houston, Texas
Posts: 1,071
SOunds like the idle speed is normal. If you are experiencing harsh engagement its probably a transmission issue.
I got too many cars!! Insurance eats me alive. Dave

78 Corvette Stingray - 3k
82 242 Turbo Volvo - Manual - 270k
86 300e 5 speed manual - 210k
87 420sel - 240k
89 560sl - 78k
91 420sel - 205k
91 560sel - 85k
94 GMC Suburban - 90k
97 Harley Davidson Heritage Softail - 25k
00 GMC Silverado 1 ton 30k
Reply With Quote
Old 01-15-2002, 01:28 AM
Registered User
Join Date: Jun 1999
Location: Surrey, Beautiful British Columbia, Canada
Posts: 750
i would second dave's opinion, could be your transmission.
Reply With Quote
Old 01-15-2002, 10:50 AM
Posts: n/a
I asked my dad about it and he said it was the rear axle and it would be around a $180 job, or something like that...Could that be it??

Thank You
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
very high idle problem. Please come in rnmb Tech Help 2 03-06-2004 10:58 AM
Help me fix my high idle please: (I searched before posting) ScottyC190E Tech Help 3 01-08-2004 01:53 PM
high idle still - stumped jchip Tech Help 8 02-17-2003 03:33 PM
High idle on my M103 dracman Featured Cars 0 10-16-2002 10:42 AM
Idle speed too high CAlford SL Forum 1 11-02-2001 10:46 AM

All times are GMT -4. The time now is 04:59 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page