PeachParts Mercedes ShopForum

PeachParts Mercedes ShopForum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   1995 E320 Transmission stuck in 1st - no upshift (http://www.peachparts.com/shopforum/tech-help/300156-1995-e320-transmission-stuck-1st-no-upshift.html)

eurosport 06-09-2011 10:08 PM

1995 E320 Transmission stuck in 1st - no upshift
 
I just had a shop install a used tranny from my other mechanic's 95 E320 sedan into the same year E320 wagon.

Had the shop that was doing the install replace the filter and filled it with Dex III (although generic brand).

Picked up the car today and it will not upshift (just stuck in 1st)

Any ideas? The mechanic that sold me the tranny said that I should do a hydraulic pressure test as maybe the shop did not position the TC correctly.

Any help would be appreciated - just drove it 4 miles (under 20 MPH) so I am hoping there was no damage done

ps2cho 06-09-2011 10:58 PM

You can't put the TC on wrong...it either fits or you break the pump gear trying to put it in the wrong way. Something else is probably going on.

autoworrks320 06-10-2011 01:09 AM

e320
 
Start looking for another tranny or rebuild one of the 1's you have. That tranny stuck in 1st is likely toast.


All times are GMT -4. The time now is 04:50 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website