Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-12-2011, 08:26 PM
Registered User
 
Join Date: Jun 2011
Posts: 1
Exclamation Transmission.

Hey guys. I did my oil changed and I did over fill so the screen was showing high oil. After that I went to walmart to put the oil at the right level. Now my car is not running well. To start up I have to press deeply the pedale to get get more power to forward and I have the check engine light on displaying the code P0700. My car truck is ML320 2001.
Reply With Quote
  #2  
Old 06-12-2011, 08:50 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
I think the info on the screen is for engine oil, I don't think anything monitors the transmission oil level. There IS a monitor for the engine oil level. Engine takes 8.5 quarts of oil.
Mercedes should not be taken to Walmart for service.
Especially for transmission service.
The trans fluid is special stuff, they do not sell it at Walmart.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page