Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-21-2002, 06:47 AM
Registered User
Join Date: Jul 2001
Location: Motor City. MI
Posts: 73
'90 300E trans.

got the 'no-fwd.-gears-blues' in this car. read the posts e: this problem & want to chk. the easy stuff first. does anyone have a pic showing the location of 'B2 Pin' & 'B2 Piston' ? TIA.
Reply With Quote
Old 01-21-2002, 08:25 AM
Registered User
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,768
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: headlight wipers, other misc parts, 300E, 190D hanno Mercedes Used Parts For Sale & Wanted 7 03-18-2004 05:00 PM
Trans stuck or ???? 1981 300 TD BillGallagher Tech Help 0 08-26-2003 09:16 PM
Sliping Trans on 87 300E euro TICOBENZ Tech Help 0 08-09-2002 10:55 AM
Can 300E Trans be modified to start in first gear? brewtoo Tech Help 2 11-25-2001 10:57 PM
TRANS 91 300e CHAM Tech Help 9 04-30-2000 09:20 AM

All times are GMT -4. The time now is 07:42 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page