Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-21-2002, 11:43 AM
Posts: n/a
Question high idle 300e...2000rpm

After replacing my head gasket ,I can't get my idle down. It's at 2000 rpm at start up and drops down to about 1700 rpm.
You have to hold on the break hard to put it in gear.


Mike V
Reply With Quote
Old 01-21-2002, 12:31 PM
Registered User
Join Date: Dec 2001
Posts: 565
This post might be worth looking at.

300 E - High Idle Speed
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
W126 medium high idle Mattman Tech Help 9 08-07-2004 05:53 AM
Another 300E rough idle cure psfred Tech Help 18 08-02-2004 05:09 PM
Does the OVP cause the 190E to have a high idle KENGRANGER Tech Help 0 06-15-2004 11:40 PM
93 300E - Rough idle after 02 sensor, air mass sensor, OVP relay, wiring harness, etc dordal Tech Help 12 11-20-2002 02:54 PM
High Idle RPM when Cold - '86 300E hs_300e Tech Help 2 10-27-2002 10:48 AM

All times are GMT -4. The time now is 09:16 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page