Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

View Poll Results: Rough idle & hesitating 190E 16V
vB code ON 0 0%
HTML OFF 0 0%
Voters: 0. You may not vote on this poll

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-21-2002, 06:39 PM
JGrif115
Guest
 
Posts: n/a
Angry Help! Out of Patience 190E 16V

My 1987 190E 16V WAS running great. However it ran warm (110C) when standing in traffic for over 15 mins, but cooled down once we started moving. The auxiliary fan didn't make any difference. All of the sudden it's developed a miss at idle speed and a hesitation when first taking off. I've changed the: Fuel pump, the rotary cap, the sparkplug resistors and sparkplugs and it's still the same. I do not know if the almost overheating has anything to do with this new problem, but when you first start the car, it runs fine. after it warms up to 60C it starts missing & hesitating. If anyone can help, please do so. I do not live in a Mercedes oriented community, so there isn't a Mercedes mechanic within 50 M of me. (Not that I can afford their rates) So I'm trying to do it myself. Thanks. Jim
Reply With Quote
  #2  
Old 01-21-2002, 07:04 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Try checking the compression & if possible a cylinder leak test.
What was the last time the valve clearance was checked or adjusted??
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 01-21-2002, 09:46 PM
Dave McDonald
Guest
 
Posts: n/a
First, change your thrermostat, second check the fuse in your overload protection relay, located behind your battery. Should have a red cap on it with a 10 amp fuse. one other thing maybe, oxgen sensor. Check it out. Please check these possibilities prior to spending unnecessary cash. p.s. Know my stuff. Doctor Fitz (407) 977 0874
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
500E vs. 190E 16v pentoman Performance Paddock 25 02-26-2007 02:46 PM
190E 8V to 16V conversion Monchit Performance Paddock 1 09-22-2003 06:12 PM
190E front hub bolt patterns: 190E 2.3 vs. 190E 16v haasman Tech Help 5 04-02-2003 05:29 PM
Help! Out of Patience 190E 16V JGrif115 Tech Help 0 01-21-2002 06:24 PM
Help! Out of Patience 190E 16V JGrif115 Tech Help 0 01-21-2002 06:13 PM



All times are GMT -4. The time now is 03:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page