Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-25-2011, 05:48 PM
Registered User
 
Join Date: Jan 2008
Location: Ontario, Canada
Posts: 8
Climate Control Problem- 1991 300CE

1991 300CE climate control problem. Read for three hours but could not find a soloution in the posts here. It appears that my system is in default mode according to several posts, however could not find a specific answer.

A/C works, heat works, fan controls work.
Tested for leaks in vacuum with mityvac at Y7 switch-over valve unit and could find no leaks. Tested footwell pod and opens and closes as it should with no leakage with the mityvac.
Took CCU out of my working E420 to test if unit was OK. Appears fine.

Now the problem - heat and A/C all work but only come out of defrost and side vents. Nothing out of the lower/footwell vents and very little out of the middle vents.
Could this be the switch-over valve or the check valve? How do I further test these, or has anyone come across this before?
Any help is most appreciated.

__________________
Reply With Quote
  #2  
Old 07-25-2011, 08:33 PM
Registered User
 
Join Date: Oct 2004
Location: Baton Rouge La
Posts: 2,631
typical problem..... center pods go bad....

__________________
1989 300ce 129k
( facelifted front,updated tail lights, lowered suspension,bilstein sports, lorinser front spoiler, MOMO steering wheel, remus exhaust,stainless steel brake lines). (Gone)

1997 s320 154k (what a ride). Sold with 179k miles. Replaced with Hyundai Equus

1994 e320 Cabriolet 108k



1972 280se 4.5 153k Owned for 12 yrs, sorry I sold it


[/SIGPIC]
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page