Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-31-2002, 06:45 PM
Senior Member
Join Date: Nov 2000
Location: SW Chicago Suburbs, IL
Posts: 250
W126 Wiper Motor Runs, Wipers Not Moving

Quick question...
I cleaned off about a foot of snow from the car this morning. When I got in I turned on the wipers to clean the windshield the rest of the way and heard a POP sound. I noticed the wipers were not going back and forth. Opened the hood for a better idea of what was going on. I can hear the wiper motor running, but the wipers are not moving. They can be moved back and forth by hand and the headlight wipers work fine. When moving them by hand, every now and then they will catch and move about 1 inch, but that's about it.

I bid on a wiper transmission and motor from eBay for around $55 for both.

Does this sound like the wiper transmission needs to be replaced? If so, how difficult is it? I've got the W126 CD's, but some first hand advice would be helpful.
Lance Allison

Sold: 1987 MB 300SDL, 320k miles, Astral Silver, Blue Leather, all books and records from day one.

Totalled: 1998 VW Jetta TDI, 488k miles, Classic Green/Gray Leather, loaded, E-Codes, "Slightly" modded, "Slightly" faster than stock, arrived 11/07/1997.

MBCA Member, Chicago Region
Reply With Quote
Old 01-31-2002, 07:00 PM
sixto's Avatar
smoke gets in your eyes
Join Date: Jun 2000
Location: SF Bay Area
Posts: 18,746
I've only worked on W116 wipers. It could be that one of the ball and socket joints in the wiper assembly came apart. You might be able to just pop it back together. If the W126 is anything like the W116, it should quite easy to get to the wiper assembly. I hope it's not like the W116 that needs new windshield grille rivets.

If you have to take the assembly apart, consider new seals where the wiper shafts go through the case. A bad seal led to corrosion inside the wiper assembly in my W116.

91 300SE
81 300SD
78 450SEL (sold)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB - Euro Headlight Wiper Setup - 1987 300SDL W126 Smooooth Mercedes Used Parts For Sale & Wanted 9 01-20-2005 05:41 PM
wiper Repair W126 Cigar Havana Tech Help 3 01-02-2005 11:01 PM
Need new W126 Wiper linkage cam69ss Tech Help 0 05-19-2004 12:25 PM
int. wipers & headlight wiper autounion SL Forum 0 03-30-2004 09:24 AM
Euro Headlight Wiper system for W126 cam69ss Tech Help 0 09-18-2002 10:50 PM

All times are GMT -4. The time now is 06:29 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page