Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-01-2002, 08:06 AM
Posts: n/a
350SDL climate control

I am having a problem with my climate control. Sometimes regardless which switch position the pushbuttons on the control panel are in I do not have any air conditioning and most of the air blows out of the defroster. After a day or two everything starts working normally again. It may work for several weeks before the problem reoccurs. When it's working it works great. Any ideas?

Reply With Quote
Old 02-01-2002, 08:21 AM
Mark Elrod
Posts: n/a
Climate Control

Sounds like a vacuum leak issue. Either the main line to the vacuum valve distributor has failed, generally under the hood at the fuse box shroud or at the distributor itself. (Located on the right side of the console just under the tunnel kick panel.) Loose connections or a crack in the plastic line will create this issue. No vacuum default air door position is 100% defrost.

Good Luck.
Reply With Quote
Old 02-03-2002, 05:24 PM
Posts: n/a
Thanks Mark

I suspected a vacuum leak. Thanks for giving me a place to look. I guess if I'm going to own a Mercedes that I will have to purchase a vacuum tester since that seems to to the root cause of a lot of Mercedes problems.

Thanks again
Reply With Quote
Old 02-03-2002, 11:00 PM
Larry Delor's Avatar
What, Me Worry?
Join Date: Jun 1999
Location: Sarasota, Fl.
Posts: 3,028
An item that I would check is one of the vacuum actuated servos. Once you remove the glovebox insert, you will see it on the left. With the engine running, see if you can see it moving right after changing from defrost to any other function ( besides "off"). You can even undo one or both of the vacuum lines, and see if you get any movement in either direction..( the little rod ought to move up or down). If you are really curious you and take it out ( turn unit counterclock wise about 45 degrees and pull it out) and then gently pry the sections apart ( you will see how to do it once you look at it) inside there should be two springs and some diaphragms...if either diaphragm is shredded, you know what to do... .... Order them from here, of course!

btw.. there are two other servos that work in tandem for the recirculating air flap.. if the are sluggish to move, or barely move, then one or both is busted also.

PS: no, you cant just buy the rubber diaphragm, you have to buy the whole kin-n-kaboodle

hope this helps...

"...rationality of thought imposes a limit on a person's concept of his relation to the cosmos." -Nash

04/71 280SE 195k
09 Jetta TDI
Reply With Quote
Old 02-04-2002, 03:48 PM
Mark Elrod
Posts: n/a
Climate control bladders

Sorry, you can purchase just the bladders, the are about $4.00 each and work GREAT.
We have a supplier here in Atlanta that carries them. I do not want to provide competetion information to the PartsShop, but if you e-mail me we can discuss.
Reply With Quote
Old 02-05-2002, 08:21 AM
Posts: n/a

If a vacuum line or servo is leaking, why would it work sometimes and not others? Seems that once the leak occured that it would always leak. Could it be coming fromt the Climate Control Unit (Push Button Unit) itself? Possibly a cold or weak soilder joint at one of the push buttons? That may cause it to "connect" sometimes and not others.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need non-working climate control, temperature and cruise control modules mplafleur Tech Help 1 03-18-2007 06:24 PM
Climate control problems mnoll4060 Tech Help 7 10-05-2004 12:57 AM
Climate Control in 420SEL flips from cold to hot William Tech Help 1 08-15-2003 06:17 AM
380SL climate control problem mike380 Tech Help 2 04-14-2003 01:33 AM
Climate Control awfrance Tech Help 3 03-04-2003 09:10 AM

All times are GMT -4. The time now is 08:34 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page