Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-03-2002, 10:01 PM
Posts: n/a
A different ASR problem on '92 500E

It starts with a sound like a air pump was pumping, after 2 to 3 mins later the ASR MIL light came on and the air pump pumping sound stopped. After the ASR MIL light came on, except the ASR stopped working and the throttle got a very little bit heavier but everything else were still functioning normally. At least I felt they were. Usually, my car did not go to limp mode except once and cruise control was working too.

It always happens when the engine is warm. It can be during the car is moving or right after started it again after sit for a while (15 mins to 4 hours). It does not happen when I drive it first time in the morning or after it has sit for a long time (6 hours or more). It did not happen when ambient Temp is above 50F and get worse when ambient temp get colder. It got into limp mode once when ambient temp is 0 F, but I still can drive it at 3 gear.

After dealer read the code, they said I needed to replace
Stop light switch
Brake Switch
ASR pressure Switch
Gas actuator
ASR control

Are there any other small things that my dealer can check before I replace the big items?

If I keep driving my car with ASR MIL light on, will I cause other damage to my car, for example Brake system, or engine?

Plesae help and Thanks in advance.

Best Regards
Reply With Quote
Old 02-04-2002, 08:01 AM
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
I hope you didn't pay much for that analysis. It sure don't take much work to just list all the parts that the codes suggest. Real diagnostics would figure which is the problem. (my guess would be what they called the "gas actuator" otherwise berated as the infamous "Throttle actuator").

I never accept multiple answers for intermittant problems and hate coincidenses.
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
Old 02-04-2002, 08:02 AM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
The brake lamp switch is a good starting place & not expensive at all.
Of course the most likely problem is the throttle actuator.
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear suspension problem W124 500E Goofy Tech Help 0 06-01-2004 10:44 AM
Rear Suspension problem 500E Goofy Performance Paddock 0 06-01-2004 10:43 AM
93 500E ASR Light came on(This is Different) aldedmon Performance Paddock 4 08-27-2002 07:41 AM
600SL ASR Problem Robert Nelson Tech Help 5 05-21-2002 01:27 PM
ASR on 500E LJADJA Performance Paddock 2 04-30-1999 06:29 PM

All times are GMT -4. The time now is 06:14 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page