Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-04-2002, 03:09 PM
zackc
Guest
 
Posts: n/a
'83 300D -Blower dead some mornings

On some mornings the heater blower on my 300D will not start up no matter which buttons I push. It seems to me a motor either is good or bad but not
intermittent like this.

Is there a relay that could be sticking on cold mornings, or is there vacuum involved?

If it is the blower motor itself, do I get at it from under the dash or from the firewall,
and how big a job is it?

I also have a problem directing the heat to the floor. It seems no matter which button I hit the heat gets distributed evenly among the floor, dash, and defroster outlets.

Any thoughts?
Thanks,
Zack
Reply With Quote
  #2  
Old 02-04-2002, 04:44 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Almost all MB's have a cold engine lock-out of the blower motor! This keeps you from freezing yourself until the engine warms up.
IF you ask for heat & the engine is cold the blower isn't susposed to run. TRY asking for A/C by rotating the temp wheel to the MIN detent & then see if the blower will work. OR even defrost.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 02-04-2002, 10:50 PM
Registered User
 
Join Date: Jan 2002
Posts: 18,353
blower

I have some oddities with my blower also. When the engine is cold, it only blows on defrost. When the engine is warm, it will only blow on the other settings if I first turn it on with the defrost setting. Once the engine is warm and I shut if off and start it again before the engine cools off, it will run in the other positions without first beginning with the defrost. I suspect it has something to do with the sensor that keeps the blower off until the engine is warm.
Reply With Quote
  #4  
Old 02-05-2002, 12:32 AM
Registered User
 
Join Date: Dec 2001
Location: Chicago
Posts: 100
It sounds like my problem.

My blower would not work if the weather is cold and it only worked when it was a bit warm outside. Replaced the thermo, the monovalve and still no go. Finally found out that the ignition switch was the problem. Since the connecters on the switch are made of metal (of course) then once cold the connecters will not make contact and the blower did not have any juice. And once warm temp is in the air the metal will expand therefore making a connection and I have a blower that work.

Here is a way to check that, you need a test light. Open the fuse box when the blower is not working. Remove the fuse for the blower. And then make contact on the terminals of the fuse holder to see if the light works, if the light does not come on from either side of the fuse terminals you are not getting juice to the blower or the blower relay. Try the light from another fuse just to make sure it works.

Good luck and be careful not to short anything out.
__________________
1993 400SEL (W140) 281K
1999 S500 (W140) 163K (Sold)
2002 S500 (W220) 72K
1999 S500 (W140) 88K
You cannot simultaneously prevent and prepare for war.
Albert Einstein (1879 - 1955)
Reply With Quote
  #5  
Old 02-05-2002, 08:11 AM
zackc
Guest
 
Posts: n/a
No blower on Defrost either

On mornings when the blower doesn't operate, it
doesn't work on defrost either; I'll have to try
adjusting the temperature wheel to cold to see if that helps the next time the blower goes on strike.

I'll also check to see if I have voltage at the fuse next time. I have had the ignition switch
temporarily jam a few times lately. All other
accessories work, the rear defroster, signals,
and radio...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
300D blower motor fusel location malone Diesel Discussion 5 01-25-2003 01:48 PM
1987 300D Turbo Blower Motor Replacement jfikentscher Diesel Discussion 1 11-12-2002 03:54 PM
ac/heat blower box doors 300D ilm1967 Tech Help 1 08-09-2001 12:28 PM
300D heater/AC blower spjohns1 Tech Help 3 02-17-2001 12:24 PM



All times are GMT -4. The time now is 01:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page