Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-09-2002, 12:13 AM
Peter Janicki
Guest
 
Posts: n/a
Please Help with 88 300E

My 88 300E with 105000 miles developed a serious problem. A few weeks ago it started to stall a few seconds after I would start the car. If I waited a few minutes, it would run for a few miles and then stall again. Now, I am only able to start it and after about 20 seconds the engine stalls and after few seconds after this, the fuel pumps stop. I changed the catalytic converter before the problem developed and fuel pump relay after the problem persisted (did not help). I really do not know what to do... Is there another relay that could go bad? Are the fuel pumps bad (got two inline) or fuel filter or what else? Any advice would be greatly appreciated...
Reply With Quote
  #2  
Old 02-09-2002, 02:58 AM
elau's Avatar
Registered User
 
Join Date: Nov 1999
Location: MD.
Posts: 1,725
Have you checked your OVP? It seems alot of people are having trouble with this lately. It is located on the passenger side of the firewall. I have a '87 W124, so I think your '88 should be very similar to mine. Also do a search on OVP and there are plenty of discussions on how to inspect and change one. Good luck.
__________________
95 R129
04 Infiniti G35.5 BS
10 X204
Reply With Quote
  #3  
Old 02-09-2002, 05:15 PM
G-Benz's Avatar
Razorback Soccer Dad
 
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
I don't think this is an OVP problem...check the fuel pressure regulator...this could be the source of your stalling...
__________________
2009 ML350 (106K) - Family vehicle
2001 CLK430 Cabriolet (80K) - Wife's car
2005 BMW 645CI (138K) - My daily driver
2016 Mustang (32K) - Daughter's car
Reply With Quote
  #4  
Old 02-09-2002, 08:17 PM
Registered User
 
Join Date: Jan 2001
Location: Tucson, Arizona
Posts: 758
Is there power

Greetings Peter,

You didn't mention whether you were getting power to the fuel pumps prior to starting and while the engine is running? Can you hear the pumps running to prime the line when you turn on the ignition key? Are the pumps still running after the enine stalls and won't restart? Let's start the troubleshooting their first. If the pumps aren't running, is there power going to the pumps? Put the voltmeter on the pump leads when you turn on the key and see if there is juice making it to the pump. Post your results and we'll go from there.


Charles
__________________
"Tell me and I will listen, Teach me and I will learn, Show me and I will accomplish, Involve me and I will succeed."
'84 300SD 256,000 Gold on Brown (Mileage Award)
'86 300E 246,000 Blue on Tan
Reply With Quote
  #5  
Old 02-09-2002, 11:03 PM
Peter Janicki
Guest
 
Posts: n/a
Re: Is there power

Quote:
Originally posted by can-do
Greetings Peter,

You didn't mention whether you were getting power to the fuel pumps prior to starting and while the engine is running? Can you hear the pumps running to prime the line when you turn on the ignition key? Are the pumps still running after the enine stalls and won't restart? Let's start the troubleshooting their first. If the pumps aren't running, is there power going to the pumps? Put the voltmeter on the pump leads when you turn on the key and see if there is juice making it to the pump. Post your results and we'll go from there.


Charles
The pumps are priming and running. In fact, there is a delay between the engine stalling and pumps shutting off (they shut off like 10 sec after the engine stalls). I already went under the car to see if the pumps are working and they get power until like 10 sec after the engine stalls. They also get power when the ignition is on. I am not sure what is going on but I see these things that could go out: OVP relay, fuel filter and maybe the fuel pressure regulator but I think that when FPR goes out, it makes the car run real rich (flooding the engine) so I should get some smoke from exhaust... I really have no experience with Mercedes since I usually work on my Porsche, Nissan Pathfinder and 3000GT VR4.... But this is really getting to me...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rebadging '87 300e emr0591 Detailing and Interior 6 09-04-2007 10:12 AM
300e Door Panels....All 4 Tan and Front Blue FS!! 6cndmbz Mercedes Used Parts For Sale & Wanted 0 06-13-2004 02:32 AM
FS 300e w124 PARTS ON EBAY!!!!!!! 6cndmbz Mercedes Used Parts For Sale & Wanted 4 09-20-2003 01:14 PM
1987 300E parts car SF Bay Area -- Cheap or Free if you tow it once for me marinmbfan Mercedes Used Parts For Sale & Wanted 2 12-10-2002 03:30 AM
What is the most common Benz? vanakin Off-Topic Discussion 14 12-07-2002 06:34 PM



All times are GMT -4. The time now is 07:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page