Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-09-2002, 01:37 PM
Registered User
Join Date: Feb 2002
Location: Bend, Oregon
Posts: 112
Hardtop won't lockdown W129!

Hi All-

I have installed the hardtop on my 1992 500SL and the dash light will not go out (indicating the top is not fully secure). I have tried locking it down manually per the manual without luck. The soft top locks down perfectly.

Any suggestions???


Reply With Quote
Old 02-09-2002, 09:11 PM
Gilly's Avatar
Registered User
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
First of all you should be doing this with the engine running, gives the hydraulic motor more available amps to run.
Be sure the electrical connector is out of the way, not between the top and body (duh).
If you're OK so far, I would try raising the top switch (to get the top up away from the body) then try pulling it down again.
If you don't have any luck with all that, I would recommend taking off the hard top, raising the soft top, and let it sit overnight with the soft top raised and locked, then retry the next day. This will allow the hydraulic system to bleed any air in the system.
Let me know how it goes, either on the thread here or via email.
The latches used to hold down the soft top are the same as the hard top uses, so it's kind of baffling why it would act this way. Maybe the adjustment is a little tight on the hardtop pins so the hydraulic latches have to work harder to latch it down. I would be real hesitant to adjust anything just yet.
I assume the hardtop is original and worked fine at some point, and there has been no adjustments or damage of any type to the body?
Reply With Quote
Old 02-10-2002, 01:54 PM
Registered User
Join Date: Feb 2002
Location: Bend, Oregon
Posts: 112
Hi Dan-

Thanks for the suggestions. I actually ended up taking the car to the local MB shop yesterday and they were able to fix the top. They cleaned out the latches and lubed them up and everything ended up working fine.

I recently purchsed the car and it did not have the hard top. I purchased the hard top on Ebay.

Thank you again for your help Dan!

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
MB hardtop hoist fitted today, and photos KenSilver SL Forum 25 10-18-2006 11:14 AM
Electric Hoist for SL Hardtop slsmag SL Forum 20 03-20-2006 09:33 AM
Hardtop Seal For W107, Cant't Find, Need Help 67w108 SL Forum 3 07-14-2004 05:02 PM
W129 driver window or hardtop adjustment? Crew SL Forum 7 01-30-2004 09:58 PM
SLK hardtop problems chiefhalo Tech Help 4 11-25-2003 02:13 PM

All times are GMT -4. The time now is 08:58 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page