Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-04-2012, 09:00 AM
TROVERMAN's Avatar
Registered User
 
Join Date: Oct 2003
Location: NH
Posts: 355
Windows and sunroof stopped working - 95 E320

Just put our '95 E320 wagon back on the road after sitting for over a year. Drove it a few days, no problems. Yesterday, the car was getting its safety inspection and the mechanic put the window down. However, it won't go up; none of the other windows are working, nor is the sunroof. I don't think the front wiper is working either. Lights, blower, radio, etc still work. Car runs fine. Fuses are all fine. When pressing a window switch, the relays in the comfort module under the rear seat click, but no window operation.

Pressing the button for the rear window defogger activates the amber light, but it goes out as soon as the switch is released.

Is it possible a failing engine harness could affect the power window operation? I thought that only controlled engine-related functions. It is the original harness. 3 days ago, the sunroof would not close from the tilted up position. I used the manual close to move it and then after that the roof worked fine.

Any ideas? Right now the window is stuck down. Car has 125k miles. We're putting it back in service because its a nice car and gets better fuel economy than our other vehicles.

__________________
________________________
2002 Mercedes-Benz E320 4Matic
1995 Mercedes-Benz E320 Wagon
2005 Land Rover LR3 V8 SE
1999 Audi A8 4.2L quattro
Reply With Quote
  #2  
Old 04-04-2012, 09:22 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Power window/sunroof computer is a stand alone system.
Located under the rear seat.
Check for power from fuses to the module, fuses A, C, G, H, 1, 2, & 9 ARE involved.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 04-04-2012, 09:47 AM
TROVERMAN's Avatar
Registered User
 
Join Date: Oct 2003
Location: NH
Posts: 355
mbdoc,

Every single fuse in the box under the hood is fine. I even wiggled all of them as sometimes I know the connections can be dubious.

I removed the box from under the rear seat, and took off the cover. I had someone else press all the window switches one at a time while I watched the relays. Every relay activated for each up / down press of each switch. It seems the problem is downstream of this module? But what?
__________________
________________________
2002 Mercedes-Benz E320 4Matic
1995 Mercedes-Benz E320 Wagon
2005 Land Rover LR3 V8 SE
1999 Audi A8 4.2L quattro
Reply With Quote
  #4  
Old 02-14-2017, 12:11 PM
Registered User
 
Join Date: Feb 2017
Posts: 1
Hey, did you ever figure this out? My sister's been having the same problem with her e320. I don't know the part number but the computer that controls the motors for the windows and sunroof needs to be replaced in hers. Hope that helps if you're still looking. I couldn't find the part anywhere though.
Reply With Quote
  #5  
Old 02-14-2017, 08:58 PM
Registered User
 
Join Date: Dec 2002
Location: New Castle County, DE
Posts: 1,031
If any of the above results in one needing the control box/module I've have a used one.

However, looking at the fuses and finding they "look good" doesn't mean they are electrically good. A simple continuity test should be done first, although a yearly "twirling" of the fuses should be on every maintenance plan.

__________________
Hanno
'79 6.9 Sold (after 27 years of ownership)
'83 280SL, 5 spd.
'94 E320 Sdn. 5 spd conversion
'95 E320 sedan
'02 E320 Sdn.(on loan to mom!)
'87 300E (5 spd. conversion) Sold
'05 E500 Wagon
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page