Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-18-2012, 06:09 PM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,034
420SEL & 300SD Oil Analysis Report Thoughts?

Hey everyone,

I sent in my 420SEL and 300SD's oil for some analysis at Blackstone Labs...

Heres the results, any one have any thoughts? The SD came back pretty good, the 420 they seemed to think something was up with it...

420SEL:



300SD:


__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

82 300SD 145k
82 300SD 265k
87 420SEL 230k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
  #2  
Old 04-19-2012, 01:25 AM
Hit Man X's Avatar
I LOVE BRUNETTES
 
Join Date: Sep 2004
Location: FUNKYTOWN
Posts: 9,085
Thumbs up

Some of mine are perfect, some are bad. If the car runs fine, keep motoring. The 420 has nearly a quarter million miles on it...not much you can really do...

At least you have no major issues and know your OCIs are a bit too long on that car.
__________________
I'm not a doctor, but I'll have a look.

'85 300SD 245k
'87 300SDL 251k
'90 300SEL 326k

Six others from BMW, GM, and Ford.

Liberty will not descend to a people; a people must raise themselves to liberty.
[/IMG]
Reply With Quote
  #3  
Old 04-19-2012, 01:15 PM
ps2cho's Avatar
Registered User
 
Join Date: Jun 2006
Location: Chandler, Arizona
Posts: 3,523
Doing a lot of hot starts when the weather is warm? Starting ever when the engine is up near red zone due to heat soak?
__________________
2016 Monsoon Gray Audi Allroad - 21k
2008 Black Mercedes E350 4Matic Sport - 131k
2014 Jeep Wranger Unlimited Sahara - 62k
2003 Gray Mercedes ML350 - 122k
Reply With Quote
  #4  
Old 07-19-2012, 10:16 PM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,034
Well I've been tracking some oil consumption on the 420SEL:

Changed at 215,088
Added 1.2-1.5 quarts at 216,411 (1323 miles later)
Added 1.2-1.5 quarts at 217,260 (850 miles later)



It might be time for valve stem seals or maybe redo the heads?

__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

82 300SD 145k
82 300SD 265k
87 420SEL 230k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page