Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-13-2002, 08:28 AM
Trampas
Guest
 
Posts: n/a
420SEL Tansmission Question

I just got a 1988420SEL with 158k miles. The car is great expect intermide transmission problem. The car usually after taking a corner will not shift into a gear, I think it is slipping when trying to down shift into second or third. It does not do this all the time. I have changed the fluid and filter trying to fix this problem. Does anyone else have a suggestion?

Thanks
Trampas
Reply With Quote
  #2  
Old 02-13-2002, 09:18 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Cornering moves the fluid away from the pick-up(filter) so try adding about 1/2 qt more fluid.
MB has a filter part number 129-277-01-95 that has a sliding pick-up that allows the fluid to be picked up better during "load" changes! IF adding doesn't help try that filter.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 02-13-2002, 09:21 AM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Are you sure you have the fluid level right. It sounds like you are sucking air.

Be sure when checking fluid to look at both sides of the stick and believe the lower one not the higher one.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #4  
Old 02-13-2002, 09:47 AM
Trampas
Guest
 
Posts: n/a
Fluid level

I did add about 1/2qt extra to the transmission and did the same thing. The problem has also happened when going straight. Therefore I figure it wasn't a fluid level problem.

Trampas
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
420SEL "check engine" light question fredsegal Tech Help 1 04-19-2003 10:28 PM
Radiator & Oil Cooler Question cKoeller Tech Help 1 03-25-2003 06:50 PM
Radiator & Oil Cooler Question. cKoeller Vintage Mercedes 0 03-25-2003 02:30 PM
420SEL Heater vent/center console issue Harpman Tech Help 6 01-01-2003 02:12 AM
300SEL or 420SEL that is the question... Guss Tech Help 3 04-22-1999 10:50 PM



All times are GMT -4. The time now is 02:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page