Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-26-2012, 06:44 PM
Registered User
 
Join Date: Dec 2003
Location: Palm Springs, CA
Posts: 781
Badge problem

I asm changing out a badge on my 300CE. I used monofilament line to remove the old badge. Worked great. I was then left wwith what I thought was the old glue. It was tar colored and was raised slightly above the trunk lid. I assumed thjis was the old glue from the first badge and I carefully removed it.
I then took the backing off the new badge noting that it was sticky but close to being even with the badge (not raised much above it). I carefully pressed on the new badge. However, looking down on it, the badge just doesn't seem glued on to me. Was the black stuff I removed the real adhesive?
Anziani
'93 320CE (I hope) 205K
'95 E420 126K

Reply With Quote
  #2  
Old 04-26-2012, 06:46 PM
Registered User
 
Join Date: Dec 2003
Location: Palm Springs, CA
Posts: 781
Badge problem

I am changing out a badge on my 300CE. I used mono filament line to remove the old badge. Worked great. I was then left with what I thought was the old glue. It was tar colored and was raised slightly above the trunk lid. I assumed this was the old glue from the first badge and I carefully removed it.
I then took the backing off the new badge noting that it was sticky but close to being even with the badge (not raised much above it). I carefully pressed on the new badge. However, looking down on it, the badge just doesn't seem glued on to me. Was the black stuff I removed the real adhesive?
Anziani
'93 320CE (I hope) 205K
'95 E420 126K

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page