Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-13-2002, 11:53 PM
Registered User
Join Date: Feb 2001
Location: Colleyville, TX
Posts: 225
93 400E Thermostat question

I think the engine on my 93 400E may be running cold. Even after 20 minutes of driving between 45 -55 degree temperature it barely touches 80C. When I tried to order a thermostat they ask if it is motor# 12-020-771 or 12-020-772. The guy asked me to look in the engine just above the block. When I looked the sticker that his this info is worn out and it is unreadable. Does anyone know which one I am supposed to buy ?? The engine was made in 10/92 - Stuttgart, Germany. Thanks
93 400e , 110K
86 BMW 325e, 147K
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
new 500e Ryan Featured Cars 4 01-27-2010 04:30 AM
400e MAF Question 90free400e Tech Help 2 12-10-2004 10:21 PM
Quick question On 400e Spark Plugs 90free400e Tech Help 2 11-15-2004 08:32 PM
Question for M.B. DOC or anyone else who might know Ron Brooks Tech Help 5 09-20-2002 09:43 AM
Excellent question --- Mike Mullins... Lee Scheeler Tech Help 2 04-12-1999 07:21 PM

All times are GMT -4. The time now is 05:04 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page