Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-04-2012, 02:58 PM
Registered User
 
Join Date: Oct 2006
Location: Indian Waters, Florida
Posts: 136
TACHOMETER

'91 420 SEL.
Tach stoped working. Pulled dash. Checked all connections, fuses, relay etc. All good. What does the Tack take a signla from. Is this a common problem like the speedo gears?
Any thoughts on what else I might check? Or what usally fails?

TIA, Dave

Reply With Quote
  #2  
Old 05-04-2012, 03:04 PM
TX76513's Avatar
Platinum Member
 
Join Date: Apr 2003
Location: Brandon, Mississippi
Posts: 5,203
That's fuse #5 or #6 (thinking 6) Double Dog sure the fuse is OK? Next place to look is the ring gear speed sensor.
__________________
BENZ THERE DONE THAThttp://www.peachparts.com/shopforum/...c/progress.gif
15 VW Passat TDI
00 E420
98 E300 DT
97 E420 Donor Car - NEED PARTS? PM ME!
97 S500
97 E300D
86 Holden Jackaroo Turbo D
86 300SDL
(o\|/o)
Reply With Quote
  #3  
Old 05-05-2012, 08:13 PM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,034
Based on the FSM, the tach signal is generated at the EZL module, goes to the X11 diagnostic port as well as the tachometer.

Is possible that your tachometer's capacitors have died. I was just replacing some on a clock and speedometer today. It would not surprise me if they did, they are 20 some years old now.
__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

82 300SD 145k
82 300SD 265k
87 420SEL 230k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
  #4  
Old 05-07-2012, 11:18 AM
Registered User
 
Join Date: Oct 2006
Location: Indian Waters, Florida
Posts: 136
Thanks, Jim and Tex. I'll have a look.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page