Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-06-2012, 03:38 AM
sptt's Avatar
Registered User
 
Join Date: Sep 2009
Location: Orange County, California
Posts: 691
Car starts and drives perfectly...what do I do?

I don't have any issues with my 300E right now. It starts everytime on the first turn, idles perfectly, rides like a demon, and stops on a dime. What am I to do???

Reply With Quote
  #2  
Old 05-06-2012, 06:25 AM
Registered User
 
Join Date: Apr 2012
Posts: 4
For Gods sake man, pull a vacuum hose off !!! Lol
Reply With Quote
  #3  
Old 05-06-2012, 06:34 AM
Registered User
 
Join Date: Mar 2010
Location: Los Angeles, CA
Posts: 189
"I don't have any issues with my 300E right now"

keep it that way
Reply With Quote
  #4  
Old 05-06-2012, 10:24 AM
Jim B.'s Avatar
Who's flying this thing ?
 
Join Date: May 2006
Location: N. California./ N. Nevada
Posts: 3,611
Exclamation

Count your blessings that it is not a W210 or W211 car and just enjoy it and take good care of it.


I love my 1995 E420, the balance is perfect on it, and it was built to a "cost no object" standard of build quality, TOTALLY unlike the Mercedes Benzes nowadays. And it was not cheap either, a new E 420 was the top of the line E class sedan in 1995, and it cost $53,000 which was a huge load of money back then.

There is a REASON - (in fact, many) I bought this when lots of other choices were affordable to me.



So, "just keep it" ..... BUT NOT like the English man in China wrote when his car got the Denver Boot in Shanghai:


__________________
1991 560 SEC AMG, 199k <---- 300 hp 10:1 ECE euro HV ...

1995 E 420, 170k "The Red Plum" (sold)

2015 BMW 535i xdrive awd Stage 1 DINAN, 6k, <----364 hp

1967 Mercury Cougar, 49k

2013 Jaguar XF, 20k <----340 hp Supercharged, All Wheel Drive (sold)
Reply With Quote
  #5  
Old 05-06-2012, 10:28 AM
Starstruck
 
Join Date: Mar 2009
Location: Iceland
Posts: 423
Quote:
Originally Posted by sptt View Post
I don't have any issues with my 300E right now. It starts everytime on the first turn, idles perfectly, rides like a demon, and stops on a dime. What am I to do???
I have the same problem with my 230E, been searching the forum and this seems to be the only link.
__________________
600SEL '91
300E 4Matic '88
240D '83
280SE '77
350SE '73
The most complex systems can fail in the simplest way.
Contra verbosus noli contendere verbis, sermo datur cunctis, animi sapientia paucis.

i don't believe in the lord! He's never bought me a Mercedes Benz.
Reply With Quote
  #6  
Old 05-06-2012, 10:56 AM
Registered User
 
Join Date: Nov 2000
Location: Ontario, Canada
Posts: 472
Pinch yourself.
__________________
1989 300CE - 269,000 km
1994 SL600 - 59,000 km
Reply With Quote
  #7  
Old 05-06-2012, 11:29 AM
I told you so!
 
Join Date: Jun 2002
Location: Motor City, MI
Posts: 2,830
Buy a car "that's a good restoration project" as they often list on Craigslist.
Reply With Quote
  #8  
Old 05-06-2012, 12:27 PM
Hirnbeiss's Avatar
ich fahre, also bin ich
 
Join Date: Mar 2002
Location: South Florida
Posts: 1,653
go fiddle with the engine harness, steam clean the engine compartment, or run some no-name green coolant through it.
__________________
Prost!
Reply With Quote
  #9  
Old 05-06-2012, 12:32 PM
just-n-time's Avatar
Registered User
 
Join Date: Feb 2006
Location: Louisiana266 Maloy Rd winnfield71483
Posts: 804
Question , rides like a demon

Just what dose this mean? is it bad or is this the new bad, or do you need to replace those little spheres?
Reply With Quote
  #10  
Old 05-06-2012, 12:44 PM
Can't Know's Avatar
Registered Slacker
 
Join Date: Sep 2010
Location: Sunny CA
Posts: 733
Quote:
Originally Posted by sptt View Post
I don't have any issues with my 300E right now. It starts everytime on the first turn, idles perfectly, rides like a demon, and stops on a dime. What am I to do???
Just enjoy it...and remember that feeling!!
Reply With Quote
  #11  
Old 05-06-2012, 04:49 PM
sptt's Avatar
Registered User
 
Join Date: Sep 2009
Location: Orange County, California
Posts: 691
I am so used to having to fix something on it that I was just realizing it has been running and driving great for coming up on a year now. Found myself thinking, "what can I work on with it now?" I guess I can probably get my driver seat repadded or something until something gives. Jim B., that car looks brand new!!! Very nice!

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page