Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-06-2012, 11:01 AM
Registered User
 
Join Date: May 2012
Posts: 1
92 500SL blowing black smoke @ idle

92 500SL blowing Black smoke heavy @ idle
Hi Everyone,
Have great 92 500SL great condition daily driver, 150,000 miles, well maintained, just one day started blowing heavy black smoke just at idle, this smoke is thick, so far I changed fuel filter ( next to fuel pump ) fuel pressure regulator, several vacuum hoses, nothing seems to change this embarishing problem. Mechanic's do not want to waste time because of year.
This must be a simple problem, it seems it started a little after my transmission maintenance flush.

Thanks for any advice

Reply With Quote
  #2  
Old 05-06-2012, 01:02 PM
just-n-time's Avatar
Registered User
 
Join Date: Feb 2006
Location: Louisiana266 Maloy Rd winnfield71483
Posts: 804
Two items to check

Quote:
Originally Posted by MarcG View Post
92 500SL blowing Black smoke heavy @ idle
Hi Everyone,
Have great 92 500SL great condition daily driver, 150,000 miles, well maintained, just one day started blowing heavy black smoke just at idle, this smoke is thick, so far I changed fuel filter ( next to fuel pump ) fuel pressure regulator, several vacuum hoses, nothing seems to change this embarishing problem. Mechanic's do not want to waste time because of year.
This must be a simple problem, it seems it started a little after my transmission maintenance flush.

Thanks for any advice
First dose your trans have a vacuum modulator? it might have a small hole in it, but that smoke is normally light in color. The second thing is the fuel mixture have the lamda setting checked, search lamda and X11. sounds like the air fuel ratio is off.
Reply With Quote
  #3  
Old 05-07-2012, 11:04 AM
Registered User
 
Join Date: Jul 2004
Location: NC
Posts: 1,140
Quote:
Originally Posted by just-n-time View Post
First dose your trans have a vacuum modulator? it might have a small hole in it, but that smoke is normally light in color. The second thing is the fuel mixture have the lamda setting checked, search lamda and X11. sounds like the air fuel ratio is off.
Yes, sounds rich. How is it running? How is the fuel economy?

__________________
former: 83 300D, 97 C230, 93 400E

current: 08 C300 Luxury , 92 500SL
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page