Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-21-2002, 11:54 AM
Posts: n/a
A Mystery

My '84 190E died on me one afternoon almost 2 weeks ago, it was acting like the battery was dead, I jumped it, took it to the mechanic, had the battery & alternator tested, the alternator tested bad, I decided to hold off on the alternator for a few days while I shopped around for a part that I could afford & the car ran fine for over a week when it died again. I pulled the batery out and had it tested by itself, turns out the battery was for a deisel engine and was sulfated. Had the battery replaced, had the alternator tested again, this time the alternator tested OK. Car ran fine for 2 days and died again, same problem, it's acting like the battery is dead.

What can cause inconsistant results in the alternator testing? The 2 tests I had were both load tests. Something tells me that it's not the alternator, what other things can cause charging problems?
Reply With Quote
Old 02-21-2002, 12:15 PM
Posts: n/a
Doesn't matter if battery was for diesel - probably just more reserve and cranking amps. Suggest you change the regulator-brush pak on your alternator - brushes are probably shot. Use search to find previous threads on this subject. Contact Phil at Fastlane to get the part pronto.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1989 420 Sel Mystery lefthandy1 Tech Help 9 03-06-2006 02:28 PM
Quietest my engine has ever run-Marvel Mystery oil willrev Diesel Discussion 34 01-16-2005 09:49 AM
Marvel Mystery Oil - any experiences? SCOTTFISH Tech Help 18 08-30-2004 12:50 AM
WWII Mystery closer to being solved. sfloriII Open Discussion 6 04-14-2004 10:47 PM
Mystery Motor Mount/Shock? 96C280 Tech Help 1 02-09-2004 12:29 PM

All times are GMT -4. The time now is 12:51 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page