Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-21-2012, 12:46 PM
Registered User
 
Join Date: Jun 2001
Location: California
Posts: 324
2002 E430 A/C blowing warm air

I just wanted to say thanks to everyone, and especially MBDoc and Gilly, for sharing their experience.

My E430 A/C has not been operational for quite a while while sitting at a stop on warm days (basically when you need it the most). After reading and searching I dug into it.

My aux fan belt between the active and passive motors had jumped off the pulley and jammed between the active fan and the condensor, causing the fan motor to burn out. It was an easy repair, and I was happy that I didn't need a control module as well

Gilly made a comment in one of the threads about how he sprays degreaser all over the front of the condensor and then rinses it with water to clear the crud out. I vacuumed the front of mine, but didn't think to wash it. Man, the black crud that came out was nasty! What a great tip!

Thanks again Guys!!
__________________
D.H.

04 ML500
02 E430

Experience is something you don't get until just after you need it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page