Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-23-2002, 04:37 PM
Registered User
 
Join Date: Feb 2000
Location: San Juan PR
Posts: 46
Question C320 key problems

The C320 that I am driving has a problem with the key.It will somtimes lock and unlock the car when using the remote other times it will not work.
Also,the ignition sometimes does not recognize the key until I reinsert it.I have tested the batteries and they seem to be fine.Any ideas?
__________________
Jerry DC
99 E430 "Stock"
Reply With Quote
  #2  
Old 02-23-2002, 10:05 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
You may have to just replace the key. It almost sounds like it was wet at some point.
__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS
Reply With Quote
  #3  
Old 02-23-2002, 11:52 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
We've had some bad keys, especially on the new C class for some reason.
The batteries may have an effect on the remote locking function, but as far as the car ignition switch recognizing the key, the batteries are not part of this operation, just the radio frequency section of the key for locking and unlocking.
You want ot make sure the dealer orders and REPLACEMENT key for the defective key, not an ADDITIONAL key, there is a difference on the 203 chassis.
Gilly
Reply With Quote
  #4  
Old 02-23-2002, 11:55 PM
Registered User
 
Join Date: Mar 2001
Location: New Jersey
Posts: 59
Definately go to your dealer. MB knows of the key problems esp. with the C class. You probably are still under warrenty.. they will replace both. I had the same exact problem.....just got two new keys.. took about 4 days to get them. There is a problem with the transponder in the original keys... takes a while to show itself. New keys apparently tuned differently.
__________________
RSL007
1999 ML430
2001 C320 Sport
2000 SAAB 9-5
1998 E300DT
1998 C280sport
1991 300D
1991 350SDL
1982 300DT
1972 Porsche 911 Targa
Reply With Quote
  #5  
Old 08-31-2002, 10:54 AM
mondo1146
Guest
 
Posts: n/a
We had a key problem with our new C320. My wife's key quit unlocking the car even though mine worked fine. The dealer replaced both keys and everything is fine now.
Reply With Quote
  #6  
Old 08-31-2002, 04:31 PM
blackmercedes's Avatar
Just a guy
 
Join Date: Dec 2000
Location: St. Albert, Alberta, Canada
Posts: 3,492
I understand there are two problems that can come up:

1. The key itself is not functioning properly, and replacing the key will solve the problem.

2. The EIS is malfunctioning, and the ignition switch will have to be replaced.

On my 1998 C230, the key would be recognized, then start the car, then the car would die immediately. It did it with all keys, seemingly at random. A new EIS solved the problem.

If your problems occur with only one key (try switching keys if you use one more than the other) then the key itself is probably the culprit. Otherwise, look to the EIS.

Talking to W203 owners, all seem to have key problems.
__________________
John Shellenberg
1998 C230 "Black Betty" 240K

http://img31.exs.cx/img31/4050/tophat6.gif
Reply With Quote
  #7  
Old 10-23-2002, 01:06 PM
arr320's Avatar
Registered User
 
Join Date: Aug 2002
Location: AL USA
Posts: 26
Arrow

I as well had a problem with my 2001 C320 key’s. I brought it up to the dealership and they took care of it by ordering new keys for it. But still I have been getting problems with the system. Some times the key will not lock the car; or it will not adjust the seat, mirror’s, and steering wheel. I am thinking of bringing up the problem next time I visit the service department. Do you guys think that my EIS is bad?

Thanks Becky
__________________

2001 C320 Sport 17" AMG Potenza S03
1991 500SL 18" AMG Contysport
1993 190E 2.6 17" AMG Contysport
2002 G500
Reply With Quote
  #8  
Old 10-23-2002, 04:12 PM
Registered User
 
Join Date: Aug 2002
Location: Connecticut
Posts: 57
I have a 02 c320. Mine locks and unlocks fine, but the memory features are erratic. Mirror an seat don't always come to the proper position. Pressing the appropriate memory button brings the seat and mirror into the correct location. Not a big deal, but annoying in a 44k car.

I figured I'd let it go until my first service at approx 10,000 miles.

Brian
============================


Becky wrote:

I as well had a problem with my 2001 C320 key’s. I brought it up to the dealership and they took care of it by ordering new keys for it. But still I have been getting problems with the system. Some times the key will not lock the car; or it will not adjust the seat, mirror’s, and steering wheel. I am thinking of bringing up the problem next time I visit the service department. Do you guys think that my EIS is bad?

Thanks Becky
Reply With Quote
  #9  
Old 10-24-2002, 07:56 AM
LarryBible
Guest
 
Posts: n/a
I expect the key problem was fixed before the introduction of the '02 models. Mine is an early '01 and they had to replace the keys with updated versions to repair this problem.

Have a great day,
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ignition key does not work all the time admanles Diesel Discussion 15 11-15-2004 12:44 PM
Ignition key lock problems tablahan ML, GL, G-Wagen, R-Class, Unimog, Sprinter 1 09-11-2004 09:43 AM
Master key -- Alarm DanielG SL Forum 0 05-20-2003 06:19 PM
Wierd! Brake wear light on key off, no glow key on. Mack Diesel Discussion 4 04-08-2003 05:59 PM
W124 Car Key Agron80 Tech Help 2 06-22-2000 05:00 PM



All times are GMT -4. The time now is 06:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page