Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-04-2002, 09:39 PM
Dan Moore
Posts: n/a
Cool W124 300TE 4Matic


I have a 91 300TE 4Matic. Great car and drives well, however it is very sluggish through the rev range. 2nd gear drive off is so poor that we have to kick down to 1st to move off the mark.

We have had the car for 12 months, my wife uses the car and complains that it is like driving a wet sock around! The car is regularly serviced and the local MB Dealership advise that it is normal, and suggest buying an ML.

I note that the 4Matic light does not come on at the igntion stage. Is this normal. Does not appear to have blown any fuses.

1) Do any of the members drive a 4Matic and have they experianced a similer performance problem?

2) Has any one used a hot chip to increase the performance.

Please advise

Reply With Quote
Old 03-04-2002, 09:52 PM
Michael's Avatar
Join Date: Jul 1999
Location: CT, USA
Posts: 2,699
Something's awry-I'm shocked a dealer would offer such a suggestion. What a fool (nothing against the ML, but clearly this knucklehead is profit-driven). Your car's no tire-smoker, but it's got adequate power. Or should.

There's no "chip" out there for your M103 motor. Sorry.

Get a second opinion-something's sapping your power and your dealer has proven he's not up to the task. Good Luck

And Yes, your 4matic light should come on for several seconds when you turn on the ignition
"If everything seems under control, you're simply not going fast enough" --Mario Andretti

1995 E500 street car
1986 Porsche 944 Turbo S track car
Reply With Quote
Old 03-05-2002, 01:04 AM
Posts: n/a
There's something wrong with your car. I have a 91 300E 4M and its a reasonably fast car. Not great from a standing start but I'd guess the 0-100 km/hr time is around 10 seconds (anyone know for sure?)- just a bit slower than a regular 300E. You should certainly have no troubles merging into traffic at a freeway on-ramp, or passing uphill, etc - and definitely no need to put it in first to get moving. Anyway, get a second opinion on it... and please update, I'd be curious to know what's going on.

91 300 E 4Matic
87 560SEL
Reply With Quote
Old 03-08-2002, 01:12 PM
Posts: n/a

If the light does not light up, does the 4Matic still activate some times? in other word does it go on if the road is slipery?
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
MOST Beautiful W124 AMG for SALE!!! FA22 Mercedes Cars For Sale 25 07-10-2008 03:19 AM
'92 300te 4matic scargo70 Tech Help 5 11-17-2003 05:18 PM
300TE 4matic questions brockley Featured Cars 21 10-02-2003 04:56 PM
W124 and 4matic Service Manuals and CD's + Becker Grand Prix Radio. 1lapgti Mercedes Used Parts For Sale & Wanted 0 08-09-2003 09:29 AM
w124 300te vs w124 e320 wagon scargo70 Featured Cars 9 06-03-2003 08:06 PM

All times are GMT -4. The time now is 05:06 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page