Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-08-2012, 11:11 AM
420benz's Avatar
Registered User
 
Join Date: Jul 2001
Posts: 961
No power to Rt. Headlight

Checked all fuses and they are OK.Opened female plug and all connections are OK.With lights on put a meter on all 4 connections and no power. Is there another place to check?
Reply With Quote
  #2  
Old 12-08-2012, 06:35 PM
Registered User
 
Join Date: Jan 2003
Location: Matthews, NC
Posts: 1,356
When you say NO power to right headlight is that LOW, HIGH, and FOG, or Just one of them? Lets say it is only the Low beam and the others work. Check with your meter at the fuse for the right low beam. If you have power there but not at the plug for the headlight then probably the Lamp Failure Module is the problem. If you don't have anything at the fuse but the left side works than you have some kind of wiring problem. In other words, we need to know exactly what works and what doesn't. Then I think we can help.
__________________
84 500 SEL (307,xxx miles)
Reply With Quote
  #3  
Old 12-09-2012, 11:05 AM
420benz's Avatar
Registered User
 
Join Date: Jul 2001
Posts: 961
Quote:
Originally Posted by pmckechnie View Post
When you say NO power to right headlight is that LOW, HIGH, and FOG, or Just one of them? Lets say it is only the Low beam and the others work. Check with your meter at the fuse for the right low beam. If you have power there but not at the plug for the headlight then probably the Lamp Failure Module is the problem. If you don't have anything at the fuse but the left side works than you have some kind of wiring problem. In other words, we need to know exactly what works and what doesn't. Then I think we can help.
Ok I went back to the fuse box and noticed there was a fuse for the upper and lower beams.Both fuses looked good until I carefully removed them. Both literally fel apart even though they looked good.Replaced both fuses and problem went away.
Thanks for that advice.Without it I never would have gone back to fuse box.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page