Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-08-2002, 11:16 PM
Posts: n/a
Successfully installed timing chain &rails 500sel

Thanks to the people on this board, especially Steve Brotherton and Mike Tangas, I was able to get my car running(it took me almost a week). Today I drove at least 200 miles. The car runs great except that somehow the vaccuum guage on the dash doesn't work now. I think I connected all the lines properly-
obviously not!! Does anybody know where to look for the guage connection under the hood? Thanks
Reply With Quote
Old 03-08-2002, 11:40 PM
Posts: n/a
Just realized when I installed new plugs this am, I may have knocked vaccuum line on driver's side loose. Sure enough, there is a second line under the one I reconnected that I knocked loose. Connected it and now it works! Car idles smoother too.
Reply With Quote
Old 03-09-2002, 02:14 AM
MikeTangas's Avatar
Senior Member
Join Date: Apr 2000
Location: So. Cal
Posts: 4,430
Good job Woody.
Mike Tangas
'73 280SEL 4.5 (9/72)- RIP
Only 8,173 units built from 5/71 thru 11/72

'02 CLK320 Cabriolet - wifey's mid-life crisis

2012 VW Jetta Sportwagon least its a diesel

Non illegitemae carborundum.
Reply With Quote
Old 03-10-2002, 12:04 PM
mplafleur's Avatar
User Friendly
Join Date: Sep 2001
Location: Lathrup Village, Michigan
Posts: 2,939
Good Job!
Michael LaFleur

'05 E320 CDI - 86,000 miles
'86 300SDL - 360,000 miles
'85 300SD - 150,000 miles (sold)
'89 190D - 120,000 miles (sold)
'85 300SD - 317,000 miles (sold)
'98 ML320 - 270,000 miles (sold)
'75 300D - 170,000 miles (sold)
'83 Harley Davidson FLTC (Broken again) :-(
'61 Plymouth Valiant - 60k mikes
2004 Papillon (Oliver)
2005 Tzitzu (Griffon)
2009 Welsh Corgi (Buba)

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
W126 Timing chain help BenzMatic Tech Help 5 08-03-2003 05:14 AM
560 SEL Rocker Arm Removal hbofinger Tech Help 10 07-23-2003 02:28 PM
Has anyone installed timing chain guide rails? woody Tech Help 4 03-02-2002 11:59 PM
Timing Chain Nightmare darius Tech Help 12 07-19-2000 05:31 PM

All times are GMT -4. The time now is 10:17 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page