Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-11-2002, 10:08 PM
Posts: n/a
When decelerating engine dies, please help?

1). For the last two weeks I've been having problem keeping RPM around 500 in slow speed, especially when suddenly decelerating to a stop, the engine dies. I am forced to constantly shift from D to N to keep the car running. 6 months ago I've changed ignition wires and cap, but not a rotor (screws were worn out). Could this be a problem? Also about the same time ago I had my fuel pump repaired by Mercedes dealer. Since than, the car sometimes chokes especially in high speed. 2). After driving on the highway around 70-80 mph for 30min. and slowing down to let say 30 mph, I smell antifreeze. What's up with that? No visible leak! Please help me out guys; I'm new to this forum but already love it.

1988 300 CE
Attached Thumbnails
When decelerating engine dies, please help?-night_front2_web1.jpg  
Reply With Quote
Old 03-13-2002, 12:14 AM
Registered User
Join Date: Nov 2001
Posts: 126
Re: When decelerating engine dies, please help?

I would suggest you find a way to change the rotor button anyway. I'm not sure of an easy way, but mauybe some other member here may have some suggestions.

Also, have you changed the fuel filter?

How does your cruise control work?
This may seem like a weird question to ask, but this is why-

1987-1988 Mercedes 300E, 300D, 300TD, 190D, 190E
Cruise control will disengage intermittently. Engine cuts out when vehicle comes to a stop.

Beginning with the production date of May 1987, the Hall-effect sensor, which is mounted on the speedometer, may have a defective cold solder joint on the sensor output pin.

If your vehicle exhibits these symptoms;

1: Cruise control will not engage at all.
2: Engaged cruise control will disengage intermittently.
3: Your 1988 vehicle cuts out when you come to a stop but will restart immediately.

Gently wiggle the output pin. If any movement is detected, the sensor is defective and should be replaced. After June 1988 an improved part was made (stamped 6.88) even though the part number remains the same.

(One more thing, I also remember reading that a bad bulb in the taillights can cause the cruise control to act up)
Reply With Quote
Old 03-13-2002, 12:38 AM
Posts: n/a
Thanks fro replying!

Amazingly you are almost totally right!

1. I did notice the cruise control not working at all last saturday when I took a trip on expressway. I have never had a problem with CControl before. Your second point is also right! Couple of times during this trip I was able to engage cruise control for maybe 5 minutes and than it stoped. Point 3. Yes after the engine dies at the stop there is no problem starting the engine back again.

No, I did not change the fuel filter for while.
What is the technical name of the Hall Effect Sensor, so I can buy it from the mercedes dealer, or maybe the partsshop has it in stock? Where is the speedometer located? Tail light bulbs seems fine, but I will check it again tomorow. Thank for your help, if you have any other suggestions please let me know

Attached Thumbnails
When decelerating engine dies, please help?-dsc00122_web.jpg  
Reply With Quote
Old 03-13-2002, 12:40 AM
Join Date: Nov 2001
Location: Cape Cod Massachusetts
Posts: 1,427
Anti Freeze Smell?

I've got an 87 SDL and in many ways its nothing like your CE and your symptoms sound nothing like anything I've experienced,but. I recently had an episode of smelling coolant immediately after shut down. To make a long story shorter I ripped out my center console, half my dash and I was going to start on the heater box when I luckily got side tracked.

I found that there was an engine coolant, heated unit that spans the width of the windshield and extends a couple of inches upward and undrneath from the windshield bottom edge, its supposed to melt ice and snow accumulating there. In my car this unit had sprung a small leak. What happens is that the coolant was leaking into a drainage bay just below the bottom edge of the windshield where the wiper motor and transmission is located on the drivers side. On the passenger side under the dash in this area is the climate control blower motor and the fresh air inlet! So when this leak occured coolant was being sprayed and dripping within inches of the fresh air intake and its' smell drawn into the passenger cabin. On my SDL you can access the area by pulling the wiper arms off (undo the 13MM nut) and pulling off a foam seal strip and five metal clips to remove the plastic grating covering this area.

I don't know if this has anything to do with your problems or particularly the coolant smell issue but I was suprised by my discovery and maybe it will help you discover something interesting about your Benz, Good Luck!
Reply With Quote
Old 03-13-2002, 12:48 AM
Posts: n/a
I will check this tomorow

I drove today 45 min on the expressway and no smell. May be the outside temperature have something to do with it? Week ago when I did smell the antifreez we had 20 F, today was 55F ( Chicago weather). I will drive it for a while and see if this incident will repeat itself. Thanks for very good tip. I'II keep this in mind, do!

Reply With Quote
Old 03-13-2002, 10:53 AM
grey500se's Avatar
Registered User
Join Date: Nov 2001
Location: VA 20 miles west of D.C.
Posts: 245
sounds like a vacuum leak
1994 Ford Taurus SHO
1999 Kawasaki Ninja ZX9R
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Additives Bill Wood Performance Paddock 6 08-24-2011 10:53 AM
'94 C280 - Intermittent No-Start & Uncommanded Engine Shutdown jgl1 Tech Help 21 05-18-2009 01:01 PM
Engine dies on startup JustinMorrison Tech Help 6 12-10-2007 12:06 PM
300SE Engine does not idle and dies Dipil Tech Help 2 01-27-2005 06:42 AM
When decelerating engine dies, please help? 88_Benz_CE Tech Help 0 03-11-2002 10:03 PM

All times are GMT -4. The time now is 09:33 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page