Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-12-2002, 10:07 AM
Registered User
Join Date: Nov 1999
Location: Matthews, NC, USA
Posts: 133
Check Engine Light returns?

My 92 500E continues to trigger the check engine light.

As best I can remember the diagnostic codes are
-crankshaft position sensor open or short circuit
-right upshift delay switchover valve open or short circuit

The car still runs perfect. Each time we clear the fault codes, the problem returns. Sometimes it takes weeks, Sometimes it takes only 2 days.

The car is box stock except for K&N's, slotted rotors, and a modification to the tranny, the valve body was modified to improve first gear starts. It was done by a local tranny shop who does a lot of MB tranny work but I am not certain exactly what was done. It does kick down a little sooner but the change is not radical as the car often does not start in first gear. As the tranny was out of the car for other reasons, the modification was not very expensive.

Any suggestions.
Reply With Quote
Old 03-12-2002, 02:17 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Up-shift delay means the trans didn't hold in gear long enough durning the warm-up period. This is a common failure. Controlled by a vacuum element in the control pressure cable.
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Old 03-12-2002, 03:47 PM
Registered User
Join Date: Nov 1999
Location: Matthews, NC, USA
Posts: 133
Thanks for the prompt response. How difficult is this to replace?

Also what is causing the crankshaft position sensor code??
Is it possible that the vacuum element is causing both?



Last edited by dwight hinton; 03-12-2002 at 04:02 PM.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light - O2 vs Coolant temp JMyers ML, GL, G-Wagen, R-Class, Unimog, Sprinter 2 11-23-2004 08:37 AM
Check engine light bigben3 Tech Help 17 12-10-2003 02:54 PM
Does Check Engine Light Reset Itself? screedchan Tech Help 7 09-27-2002 11:17 AM
Check engine Light! Bad idle! moomoomeow Tech Help 2 04-25-2002 08:02 AM
intermittant check engine light 88 300E phunkler Tech Help 1 10-13-2000 07:55 AM

All times are GMT -4. The time now is 03:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page