Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-14-2002, 02:28 PM
downsmith's Avatar
Registered User
Join Date: Jul 2001
Location: Oklahoma Sooners Alumnus
Posts: 116
Question Distributor Advance Problem?

My timing advance is not working. I know this because the timing does not cange like it used to whenI pull the vacuum hose. I have vacuum to the advance unit. Is it possible that something is wrong inside? Is there a repair kit for the advance unit on the distributor?
R. Downs
1985 500SEL (260,000 miles) SOLD!
1974 280 SOLD!
1994 Volvo 850 Turbo Wagon (Yuppie Ice Sled)

"I know I have a Benz and they know it too." If you start bragging about it or shoving in people's face, you then become a Wally; especially to the girls.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Running list of failures during 3 years of ownership Q ML, GL, G-Wagen, R-Class, Unimog, Sprinter 33 01-22-2006 08:13 AM
240D intermittant starting problem pj67coll Diesel Discussion 12 12-13-2003 07:16 AM
Electrical Problem? 87300SDLTurbo Tech Help 0 10-23-2002 02:29 AM
Igniton switch or Relay Problem cmusante Tech Help 1 10-07-2002 06:00 PM
Paying Labor Cost to look for problem!!!! Aija Tech Help 4 07-20-2002 09:13 AM

All times are GMT -4. The time now is 04:52 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page