Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-21-2002, 08:40 PM
Posts: n/a
Question 190e 2.6

I would like to thank everyone for their posts in regards to my car. I decided to take the plunge and to purchase it. I have it now. There are just a few small things that I noticed wrong with it. I would guess that I wouldn't need to fix them immediately, but I wanted to post them here to see what you all thought:

1. The gauge cluster that has the gas gauge, oil pressure gauge and oil temp. gauge does not seem to be functioning. The dealorship filled the tank for me, but the arrow was still down to empty. As I drove home, all of the gauges were at the bottom, so I'm guessing that it might be a fuse or something like that?

2. The cruise control does not seem to be functioning. I tried it a few times, and it would not engage. Possibly another fuse?

Other than these two problems, I could find nothing else wrong. The car drives like a champ. I'm looking forward to a long and GOOD relationship with my car!

Would someone be able to give me an estimate as to how much they think it would cost to have those gauges and the cruise working again?

Thanks for all of your help!
Reply With Quote
Old 03-22-2002, 07:22 AM
Registered User
Join Date: Jan 2002
Location: England
Posts: 1,841

Hope you enjoy years of MB motoring!
As for your fixes, I would recommend checking the user manual for what each fuse does, or looking on the top of the fuse box, located under the hood. The fuses are known to corrode, and not work even when they appear not to be blown. To save you any hassles, I would replace all the fuses with new ones, and clean the connectors in the fuse box, to save you any more worries!


2.5-16v 1990 90,000m Astral Silver
2.0E 8v 1986 107,000m Black 2nd owner
Reply With Quote
Old 03-22-2002, 11:04 AM
Registered User
Join Date: Jun 2000
Location: Saugus, CA USA
Posts: 1,974
Put a little grease on the connectors and fuses, it'll keep them from corroding.
5 speed '91 190E 2.6 320,000 mi. (new car, fast, smooth as silk six, couldn't find any more Peugeots)
5 speed '85 Peugeot 505 2.5l Turbo Diesel 266,000 mi. (old car, fast for a diesel, had 2 others)
5 speed '01 Jetta V6 (new wifes car, pretty quick)
5 speed '85 Peugeot 505 2.2l Turbo Gas 197,000 mi. (wifes car, faster, sadly gone just short of 200k )
5 speed '83 Yamaha 750 Maxim 14,000 mi. (fastest)
0 speed 4' x 8' 1800 lb Harbor Freight utility trailer (only as fast as what's pulling it)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
190E 2.6 info needed pentoman Tech Help 6 01-31-2005 07:53 AM
Reasonable Price for a 93 190E 2.6 w/ 90K miles Chiragp Mercedes Used Parts For Sale & Wanted 8 01-28-2005 09:45 PM
190E 2.6 one cylinder down - is mechanic right? AlexUK Tech Help 15 06-10-2004 10:22 AM
3.0 into 190E 2.6 neileg Tech Help 2 11-01-2002 11:30 AM
Reasonable Price for a 93 190E 2.6 w/ 90K miles Chiragp Performance Paddock 3 04-22-2000 11:11 PM

All times are GMT -4. The time now is 11:11 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page