Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-26-2002, 10:35 PM
Registered User
Join Date: Feb 2002
Posts: 32
Unhappy rough idle

Dear all,

I now owned a 95 SL for more than 2 months and it is a great car. It has 60 K miles on it. When i got the car, the 60K miles maintenance was performed. New spark plugs, new oil, oil filter, air filter, fuel filter, transmission fluid and filter. New engine mount was replaced. The car idles rough especially in the morning when cold. The RPM fluctuate between 800-1000. If I press the gas pedal steady, sometimes the idle fluctuate itself between 1000-15000 rpm. Once engine is warm, i still feel significant vibration, more so in neutral than in drive with slight but definite fluctuation in RPM. The car drive very well without any hesitancy.
I took the car to 2 independent shops. There was no fault codes. They change spark plugs without any improvement. I put in 4 techtron and 2 redline fuel injector cleanser without any changes. The wiring harness was inspected and said to be OK.

What else should i be looking for?
thanks in advance
Reply With Quote
Old 03-27-2002, 02:43 AM
David C Klasse's Avatar
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
Was the fuel filter (filters?) replaced at the 60k service? The MB Maintenance manual says that it is recommended, but not required. I had mine changed at 80k miles and it was definitly time to change! Symptom was a rough idle also. I'd give that a try. Good luck!

You say that one engine mount was changed? Or do you mean all were? If yes, then I'd have the other one changed as well.
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
Old 03-27-2002, 10:35 AM
Registered User
Join Date: Feb 2002
Posts: 32
thanks for the reply. Yes, the fuel filter was changed and i think both the engine mount were also changed. One thing that i know was not changed was the tranny mount. Anything else i should be looking for or i should head to the dealer?
Reply With Quote
Old 03-27-2002, 11:09 AM
pmizell's Avatar
Benz Zealot
Join Date: Jun 2001
Location: Houston, Texas
Posts: 838
Distributor cap, rotor and wires.... how do they look?

Your fuel pressure regulator could also be the culprit. Does the car start up immediately when cold, or does it take a few cranks?


'91 300E, 208k miles
Reply With Quote
Old 03-27-2002, 11:19 AM
Registered User
Join Date: Feb 2002
Posts: 32
i was told that cap, rotor and wiring looked ok. i took about 2-3 second to start when cold but immediately when warm. how do we check fuel regulator?
Reply With Quote
Old 03-27-2002, 11:25 AM
pmizell's Avatar
Benz Zealot
Join Date: Jun 2001
Location: Houston, Texas
Posts: 838

Visit this thread:

300E rough rough rough idle

Lots of possible causes including the infamous wiring harness on your '95 model. Has it been replaced?

Good luck...... use the search function, there's a wealth of info on rough idle.


'91 300E, 208k miles
Reply With Quote
Old 05-26-2002, 02:13 AM
Registered User
Join Date: Feb 2002
Posts: 32
still rough idle

wiring was ok according to independent shop. the engine still have rough idle. the mechanic told me that one of the 12 cylinders may be misfiring. engine check light never goes off. the vibration seems to come from the left side of the engine. he told me it is normal with 60 k miles car. it that true or it is time to go to the dealer? any other suggestions?
Reply With Quote
Old 05-26-2002, 02:56 AM
BENZ-LGB's Avatar
Strong, silent type
Join Date: Apr 2001
Location: Southern California
Posts: 1,663
Has your mechanic...

...performed a leak down test? Often the most obvious reason for rough idle (leaky valves) is overlooked. Even on a relatively new engine (and your 95 with only 60K miles is NEW) valves can leak for a number of reasons. So have your mechanic check this out (if he hasn't already done so).

And enjoy your car. It is a beautiful piece oof mechanical engineering. Good luck.
Current Benzes

1989 300TE "Alice"
1990 300CE "Sam Spade"
1991 300CE "Beowulf" RIP (06.1991 - 10.10.2007)
1998 E320 "Orson"
2002 C320 Wagon "Molly Fox"

Res non semper sunt quae esse videntur

My Gallery

Not in this weather!
Reply With Quote
Old 05-26-2002, 03:22 AM
Registered User
Join Date: Feb 2002
Posts: 32
thanks for the reply. i see that you are in so cal. can you recommend me a shop in LA? BTW, is valve thing an expensive proposition? mike
Reply With Quote
Old 05-26-2002, 11:15 AM
Registered User
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,768
If the CE light never goes off, then there is a fault code stored ... and that is where you go to start diagnoses .that's what the diagnostic module is there for .
go get the code ....
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough cold idle on 1991 420SEL BENZ-LGB Tech Help 15 06-20-2012 04:18 PM
240D "nailing" & rough idle TedG Tech Help 0 07-28-2004 12:44 PM
my low, rough idle, stall, hot /start solution: E320/300 rvenerac Tech Help 3 11-20-2003 09:59 AM
Idle very rough when cold Hurshi Tech Help 2 02-10-2003 01:21 PM

All times are GMT -4. The time now is 12:49 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page