Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-07-2014, 03:50 PM
barkford's Avatar
Registered User
 
Join Date: Apr 2002
Location: Charlotte, NC
Posts: 157
W210 - 1998 e300 mercedes with ortho seats

Hello:
After doing some article searching, i am hoping to confirm some troubleshooting steps for my new (new to me) e300. Symptom: the ortho seats have been completely dead since i bought the car. No hissing of air, no movement of any kind when moving either the driver or the passenger switches. The door locks and fuel filler door work fine. I do on occasion here the air pump working when unlocking doors.

Question: where to start on troubleshooting? Should i check for an air tube disconnect at the pump under the back seat? Is it possible to see these air tube connections feeding into each seat without disassembly? Just looking for the basics first.

Any advice is greatly appreciated and i am happy to update this post with what i find to share!!
__________________
Barker
Reply With Quote
  #2  
Old 01-07-2014, 05:23 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Without a diagnostic tool to check programming and inputs it will be pretty hard to do, The first thing that comes to mind is to look for a disconnected (electrical)connector at the PSE pump, since you are hearing no air leak I'd assume a tubing disconnect is not the problem. I am not sure if the PSE monitors pressure buildup in the lines and possibly would time out in the case of a disconnect, or a cut line, or a bladder leak in the seat, these all could be possiblities if the PSE pump times out.
Reply With Quote
  #3  
Old 01-09-2014, 02:28 AM
Registered User
 
Join Date: Jul 2005
Location: Seattle, WA
Posts: 527
for some reason, my brain is telling me that "MKE" port services the ortho seats.
if your pump is same as my 99 E320, it would be lower right corner.

check pump outlet for air
check hose leading to front seats air control module for air
pop off rear seat cover and check for air leak at the connectors

....and hope that it isn't in the air bladders themselves. but the manner in which
you're describing the total lack of function at all air bags, i'm thinking it something
further upstream towards the pump.

the air hoses can become hardened and fail, especially if previous owner had
man-handled them
__________________
-- raymond~
47 34'N 122 18'W
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page