Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-03-2002, 02:50 PM
Registered User
 
Join Date: Apr 2002
Location: boston ,Ma
Posts: 153
help with my 89 300e

Here is the trouble guys everytime i start the car after about 2 may be 3 minutes the engine starts idling rough , i mean shaking to a point where it would almost die then after a couple of minutes the engine would ramp up high and settle back down to where it suppose to be : this doesnt only happen in the morning when i first start the car it also happens everytime i start the engine please help me
Reply With Quote
  #2  
Old 04-03-2002, 03:02 PM
J.HIDALGO's Avatar
Registered User
 
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
Red face It sounds like the OVP?

Have you jumped your car lately? Is your SRS light on? Do a search on the right upper corner under OVP. The OVP is located behind your battery with a red fuse on top.
__________________
J.H.
'86 300E
Reply With Quote
  #3  
Old 04-03-2002, 03:12 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,777
<>

J.H. gives good advise, but I think he meant " Is the ABS light on ? "
Reply With Quote
  #4  
Old 04-03-2002, 03:17 PM
J.HIDALGO's Avatar
Registered User
 
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
ABS light it is!

Thanks Arthur!
__________________
J.H.
'86 300E
Reply With Quote
  #5  
Old 04-03-2002, 03:22 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,777
JH
I do it all the time myself...
I thing we should just call all the systems "XYZ", then we won't have to get the book out.
If you ever saw the full list... it's a Looooooong one...
Arthur
Reply With Quote
  #6  
Old 04-03-2002, 03:26 PM
Registered User
 
Join Date: Apr 2002
Location: boston ,Ma
Posts: 153
No the srs light is not on but i will check the OVP anyway the only light i have on is the one that indicate that a bulb is out or something and 2 lights on my dashboard is out wich i have no idea how to replace You guys are great thanks for the quick response
Reply With Quote
  #7  
Old 04-04-2002, 09:19 AM
Registered User
 
Join Date: Apr 2002
Location: boston ,Ma
Posts: 153
Ok guys i ended up spending about $300 bucks yesterday i still have the same problem I ending doing a full tune up on the car according to my mechanic that 's where to start I check the OVP the fuse is good I doubt that 's what the problem is but i will change it anyways but damn this is frustrating i try not to hate the damn car i like it so much but oh my GOD Please tell me what else to look for
Reply With Quote
  #8  
Old 04-04-2002, 09:53 AM
J.HIDALGO's Avatar
Registered User
 
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
I would change mechanic...

He needs to diagnosed the problem! YOU can do a tune up. Your mechanic should diagnosed the problem and THEN replace parts.
The OVP is a very common failure part in these cars and that is normally where a DIY'er starts, plus the part has been updated and it is easy and inexpensive to replace.
__________________
J.H.
'86 300E
Reply With Quote
  #9  
Old 04-04-2002, 10:23 PM
Registered User
 
Join Date: Apr 2002
Location: boston ,Ma
Posts: 153
Ok OVP is out of the question I replace it this afternoon dealer charge me $76 took it out right in the parking lot replace it in 2 secs , the car started ok but after 2 mins the rough idling started again It took the car 5 mins to come back to normal and now on the way home my check engine light came on , could the check engine light have something to do with my rough idling or what usually make the check engine light come one on a MB
Please help
Reply With Quote
  #10  
Old 04-07-2002, 04:44 PM
Registered User
 
Join Date: Aug 2001
Location: Evansville, Indiana
Posts: 8,150
Check engine light usually means that the oxygen sensor system isn't working correctly. Could also be other things, I'm not really familiar with MB gas engines.

Check the condition of the idle valve hoses -- they are probably rock hard and leaking at both ends. They are cheap, but replacement is sort of a pain. This will cause rough running and intermitant mixture problems.

Sounds like you are going very lean when the engine goes into closed loop mode -- this is when the oxygen sensor starts to work.

I found most of the vacuum lines in the engine compartment were leaking on the 300TE I bought a couple years ago -- take a look. You can either buy the MB parts or just use standard vacuum line of the proper size. The really important ones are the ones that go to the ignition computer on the fender, behind the ABS system -- if you have leaks there, the computer won't generate the correct fuel ratio.

You may also need to adjust the fuel mixture at the fuel distributor -- if it is way off, it takes a while for the computer to get it correct.

The tuneup is expensive -- I spent $350 on cap, rotor, wires, and plugs, but the car ran MUCH better after.

Peter
__________________
1972 220D ?? miles
1988 300E 200,012
1987 300D Turbo killed 9/25/07, 275,000 miles
1985 Volvo 740 GLE Turobodiesel 218,000
1972 280 SE 4.5 165, 000 - It runs!
Reply With Quote
  #11  
Old 04-07-2002, 05:10 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,777
Quote:
Originally posted by maximus
Ok OVP is out of the question I replace it this afternoon dealer charge me $76 took it out right in the parking lot replace it in 2 secs , the car started ok but after 2 mins the rough idling started again It took the car 5 mins to come back to normal and now on the way home my check engine light came on , could the check engine light have something to do with my rough idling or what usually make the check engine light come one on a MB
Please help
If you have a check eng light , the on board self diagnostics has detected a fault in the system . That means a code has been tripped and will point you in the right diagnostic direction..
The code chart will show which system/part is suspect.
Off hand , I would suspect a sticking egr valve or bad o2 sensor
as they both come into play after warm up. But the code will tell that for sure.
Don't change parts til you get the code. There are 32 fault code that will trip the light . Do a search on how to pull the codes
and how to make the tool to DIY or go get it scanned.
When you have that info, I will be happy to tell you what the chart fault suggest.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rebadging '87 300e emr0591 Detailing and Interior 6 09-04-2007 10:12 AM
300e Door Panels....All 4 Tan and Front Blue FS!! 6cndmbz Mercedes Used Parts For Sale & Wanted 0 06-13-2004 02:32 AM
FS 300e w124 PARTS ON EBAY!!!!!!! 6cndmbz Mercedes Used Parts For Sale & Wanted 4 09-20-2003 01:14 PM
1987 300E parts car SF Bay Area -- Cheap or Free if you tow it once for me marinmbfan Mercedes Used Parts For Sale & Wanted 2 12-10-2002 03:30 AM
What is the most common Benz? vanakin Off-Topic Discussion 14 12-07-2002 06:34 PM



All times are GMT -4. The time now is 05:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page