Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-05-2002, 09:36 PM
Registered User
Join Date: Mar 2002
Posts: 33
w 126 transmission question

today i test drove an 89 420 sel and teh transmission seemed to not go into the last gear. The rpms gage was at 3000 and the car was going 80mph. I thought it should down shift but wasnt sure. It just didnt feel right. The owner told me that there is a button under the gas pedal and i tried to push it while driving 80 but did not do anything as far as shifting down to a lower gear. Is this normal or am i just feeling to much for a car traveling at 80mph.

What should the rpms be at 80-85mph?

Reply With Quote
Old 04-05-2002, 09:41 PM
Registered User
Join Date: Feb 2002
Location: Orlando, FL
Posts: 788
Well this is a four speed. I am pretty sure that 3 grand is about right. The button is the downshift button and going that fast you would need to depress it to downshift. At lower speeds, you can just depress the pedal and it will downshift and if you hit the button it will double downshift..and set you back in your seat!
'86 420SE Euro
904 Midnight Blue, Gray Velour
Dad bought it new, now I own it.

"A Mercedes-Benz is like a fine wine, it only gets better with age."
Reply With Quote
Old 04-06-2002, 08:01 AM
goldenbear's Avatar
Registered User
Join Date: Mar 2001
Location: NorCal
Posts: 442
The vehicle was in 4th gear. This tranny, I believe, starts out in 2nd gear -unless- you manually put the gated shift lever on "2" -or- punch from a start.

'04 ML500 - 53k, Inspiration Edition, Desert Silver
'11 Audi A4 Avant - Brilliant Black
'87 300SDL sold
'99 C280 Sport sold
'85 190E 2.3 sold
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Late model transmission interchange question 95s420 Tech Help 2 06-05-2004 08:04 PM
Question for manual transmission owners Duke2.6 Tech Help 10 05-24-2004 03:22 AM
cold transmission question. Spo123 Diesel Discussion 4 01-22-2003 12:22 PM
transmission question jrmd01 Performance Paddock 1 09-07-2002 08:22 PM
Transmission question on C280 767Flyer Tech Help 0 08-15-2002 07:22 PM

All times are GMT -4. The time now is 03:46 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page