Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-08-2002, 12:23 AM
Registered User
Join Date: Jan 2002
Posts: 352
99 S420 Probs

LAST WEEK THE DEALER CHANGED THE OIL PUMP, SENSOR, AND DID AN OIL CHANGE ON MY '99 S420. sorry for the caps (I really am). Now this week, I see that the car is leaking oil and I have to go back and complain. (Best thing about living 3 miles away from them) The entire service department know me there and I think they are the best dealer in so cal, they are Calbasas Motorcars) What do you think could cause this problem, I fear that it is the oil seals of the engine because my 97 e320 has the same problem. The cars are usually sitting fully detailed in the garage with no movement. I try to start em up once a week but I don't think thats enough. Any posts are greatly appreciated.

99 s420 45k
97 e320 36k
96 sl600 havent checked in a while
89 300e just did an oil and filter change on it with the topsider. AWESOME. I used the Mobil 1 filter and some Mobil 1 synthetic 10w30 with some dino 20w50 to make the best m103 cocktail. also added some Valvoline fuel injector cleaner and I felt like I got at least 10 hp in all bands of the engine.
Reply With Quote
Old 04-08-2002, 06:19 AM
Registered User
Join Date: Dec 2000
Posts: 368
Most likely the oil sump gasket. I've seen many techs reuse it since they usually stay intact. I always change it no matter how new it is. Especially, on a 119 engine where you need to lift engine slightly in order to reach front bolts.

Reply With Quote
Old 04-11-2002, 07:33 PM
Registered User
Join Date: Jan 2002
Posts: 352
Fixed it today, sensor was changed again and they fixed the gasket.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
W140 - 95 S420 oxygen sensor sixto Tech Help 5 08-01-2004 09:52 PM
94 S420 M119 random engine miss (SteveB, MB Doc, ...) sixto Tech Help 1 01-17-2004 03:23 PM
95 S420 power seat gear available? sixto Tech Help 0 06-11-2003 12:34 AM
95 S420 driver's door lock and lumbar - related? sixto Tech Help 0 06-09-2003 05:50 AM
Looking at buying S420 or S320, primarily for hwy driving LAX300DTurbo Performance Paddock 6 08-20-2001 06:41 PM

All times are GMT -4. The time now is 09:07 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page