Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-08-2002, 03:53 PM
Registered User
Join Date: Feb 2002
Location: Bulgaria, Sofia
Posts: 584
16v won't start

Hi, today I washed the engine of my car, then it started up and I drove home but after 2 hours when I tried to start it again it refused. I checked the spark plugs and they fire but it seem no fuel is goig into the engine. I can here the pump working in the back. Tried to start it by pulling it with another car buy it still won't start. Where should I search for the problem ? Is there some kind of electronic fuel cuttof that might not be working because it got wet ???

190e 2.5-16v
Reply With Quote
Old 04-08-2002, 11:45 PM
Registered User
Join Date: Apr 2000
Posts: 412
The distributer may be wet try drying it with a hair dryer. The steam may have accummulated after driving the car fromthe heat of the engine. Are you getting a good spark? You have to be careful when cleaning an engine of what you get wet.
1990 190E 2.6
1996 Grand Voyager 3.3
1985 Mustang GT 5.0 5 SPD
1982 Suzuki GS 750T
Reply With Quote
Old 04-09-2002, 03:54 AM
Registered User
Join Date: Feb 2002
Location: Bulgaria, Sofia
Posts: 584
I wasn't getting a good spark. Turned out the coil that supplies the electricity to the distributor was damaged ( . Cost me $25 form a scrap yard. Never will I wash my cars engine again !!!

190e 2.5-16v

Last edited by Joreto; 04-09-2002 at 06:54 AM.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Where to begin ? Car doesn't start (doesn't turn over) renyf1 Tech Help 23 06-22-2004 11:29 AM
car won't start jude Tech Help 5 06-03-2004 11:24 AM
2.5 16v idle adjustment and cold start Uk Merc Man Tech Help 4 03-10-2004 04:46 PM
1991 420SEL - beginning of a cold start problem DieselGuy Tech Help 1 07-30-2001 03:56 AM
16v cold start question Tinker Tech Help 1 11-15-2000 10:32 PM

All times are GMT -4. The time now is 11:22 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page