Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-01-2014, 08:29 AM
Registered User
 
Join Date: Aug 2014
Posts: 6
300 SE W126 Wont Start

Hello to everyone.
Never had the need to post before as I have always been able to find the answer in another thread.
My 300SE won't start.
There appears to be good spark.
The engine does fire when I spray starting fluid into the air intake.
There is no fuel getting to the injectors.
There is fuel getting to the fuel distributor but not coming out injector ports.
The fuel pump activates and delivers what looks to be a good quantity of fuel.
When the air flow sensor flap is depressed while the engine cranks there does not seem to be an increase in resistance.
Any suggestions would be greatly appreciated.

Thanks
Alby

Reply With Quote
  #2  
Old 09-03-2014, 11:31 AM
pawoSD's Avatar
Dieselsüchtiger
 
Join Date: Oct 2004
Location: Grand Rapids, MI
Posts: 15,243
Have you tested fuel pressure, are both pumps running? Changed fuel filter? (CAREFUL you don't blow up the car/yourself as gas gets everywhere)

Could be a bad fuel distributor but it sounds like a low-pressure condition if it came on suddenly. One pump may have failed.

__________________
-diesel is not just a fuel, its a way of life-
'15 GLK250 Bluetec 88k - mine - (OC-91,200)
'17 Metris(VITO!) - 16k - wifes (OC-17k)
'01 E320 Wagon - 159k - mine (OC-160,000)
'01 E320 - 179k - dad's (OC-182,500)
'07 E350 Wagon - 133k - dad's (OC-132,500)
'01 SL500 - 52k - dad's (OC-52,000)
'16 E400 4matic Sedan - 70k - Brothers (OC-72,000)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page